classification
Title: Configure thinks it finds python3.5 but doesn't
Type: compile error Stage: resolved
Components: Build Versions: Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: vstinner Nosy List: larry, vstinner
Priority: release blocker Keywords: 3.5regression, patch

Created on 2017-09-24 09:15 by larry, last changed 2018-01-23 02:14 by ncoghlan. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 3737 merged vstinner, 2017-09-24 21:54
PR 5274 merged ncoghlan, 2018-01-23 02:14
Messages (5)
msg302837 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2017-09-24 09:15
On Python 3.5, the makefile pseudotarget "regen-opcode" now fails if "python3.5" can't be found on the path.  What's strange is that the configure script scans to see if it can find "python3.5", and it thinks it can, but then actually attempting to run it fails.

I can't merge PRs in 3.5 right now because this is broken.  Note that everything is fine on my Ubuntu laptop because I *do* have "python3.5" on my path.  But the Travis CI buildbot doesn't.

Here is an example failure on Travis CI:

https://travis-ci.org/python/cpython/jobs/279140454

I don't know how this got merged, because the PR that made this change should itself have failed.  Maybe the configuration of the buildbot has changed since we merged that PR?
msg302838 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2017-09-24 09:16
Oh, and, Victor, I tagged you with this because git blame says you're the most person to touch PYTHON_FOR_REGEN in the makefile, checkin ab6b962ef24 .
msg302887 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-09-24 21:55
The Travis CI error is:
---
python3.5 ./Objects/typeslots.py \

		< ./Include/typeslots.h \

		./Objects/typeslots.inc

pyenv: python3.5: command not found

pyenv: python3.5: command not found

The `python3.5' command exists in these Python versions:

pyenv: python3.5: command not found

  3.5

  3.5.3

make: *** [regen-opcode] Error 127

make: *** Waiting for unfinished jobs....
---

It looks like this Travis CI bug:
https://github.com/travis-ci/travis-ci/issues/8363

I wrote https://github.com/python/cpython/pull/3737 which should works around the Travis CI. Change inspired by:
https://github.com/pre-commit/pre-commit/commit/e3ab8902692e896da9ded42bd4d76ea4e1de359d
msg302891 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2017-09-24 22:45
New changeset 70c630a7316f9f6063557786442e3c56502fe8ea by larryhastings (Victor Stinner) in branch '3.5':
bpo-31568, Travis CI: Fix python3.5 (#3737)
https://github.com/python/cpython/commit/70c630a7316f9f6063557786442e3c56502fe8ea
msg302923 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-09-25 08:25
It seems like the bug was fixed. Nice.
History
Date User Action Args
2018-01-23 02:14:51ncoghlansetpull_requests: + pull_request5119
2017-09-25 08:25:15vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg302923

stage: patch review -> resolved
2017-09-24 22:45:02larrysetmessages: + msg302891
2017-09-24 21:55:24vstinnersetmessages: + msg302887
2017-09-24 21:54:16vstinnersetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request3723
2017-09-24 09:16:36larrysetmessages: + msg302838
2017-09-24 09:15:21larrycreate