classification
Title: test_smtpnet.test_connect_using_sslcontext_verified() randomly failed with "smtplib.SMTPServerDisconnected: Connection unexpectedly closed" on AMD64 FreeBSD CURRENT Debug 3.x
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, koobs, vstinner
Priority: normal Keywords: buildbot

Created on 2017-05-16 22:18 by vstinner, last changed 2017-09-15 16:29 by vstinner. This issue is now closed.

Messages (3)
msg293808 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-05-16 22:18
See also bpo-30331 (test_poplib) and bpo-30328 (test_ssl): other connection reset on the FreeBSD buildbots.

http://buildbot.python.org/all/builders/AMD64%20FreeBSD%20CURRENT%20Debug%203.x/builds/272/steps/test/logs/stdio

0:15:55 load avg: 1.77 [387/405/1] test_smtpnet failed -- running: test_subprocess (62 sec)
test_connect (test.test_smtpnet.SmtpSSLTest) ... ok
test_connect_default_port (test.test_smtpnet.SmtpSSLTest) ... ok
test_connect_using_sslcontext (test.test_smtpnet.SmtpSSLTest) ... ok
test_connect_using_sslcontext_verified (test.test_smtpnet.SmtpSSLTest) ... ERROR
test_connect_starttls (test.test_smtpnet.SmtpTest) ... ok

======================================================================
ERROR: test_connect_using_sslcontext_verified (test.test_smtpnet.SmtpSSLTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.x.koobs-freebsd-current/build/Lib/test/test_smtpnet.py", line 77, in test_connect_using_sslcontext_verified
    server = smtplib.SMTP_SSL(self.testServer, self.remotePort, context=context)
  File "/usr/home/buildbot/python/3.x.koobs-freebsd-current/build/Lib/smtplib.py", line 1029, in __init__
    source_address)
  File "/usr/home/buildbot/python/3.x.koobs-freebsd-current/build/Lib/smtplib.py", line 251, in __init__
    (code, msg) = self.connect(host, port)
  File "/usr/home/buildbot/python/3.x.koobs-freebsd-current/build/Lib/smtplib.py", line 337, in connect
    (code, msg) = self.getreply()
  File "/usr/home/buildbot/python/3.x.koobs-freebsd-current/build/Lib/smtplib.py", line 393, in getreply
    raise SMTPServerDisconnected("Connection unexpectedly closed")
smtplib.SMTPServerDisconnected: Connection unexpectedly closed

----------------------------------------------------------------------
Ran 5 tests in 7.470s

FAILED (errors=1)
test test_smtpnet failed
msg301511 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2017-09-06 20:12
Probably not a bug in the SSL module
msg302265 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-09-15 16:29
Sadly, I didn't see the bug again since I report it. So I close the bug :-(
History
Date User Action Args
2017-09-15 16:29:42vstinnersetstatus: open -> closed
resolution: out of date
messages: + msg302265

stage: resolved
2017-09-06 20:12:37christian.heimessetassignee: christian.heimes ->
type: behavior
messages: + msg301511
components: - SSL
2017-05-16 22:18:35vstinnercreate