classification
Title: test_ssl.test_connect_with_context(): ConnectionResetError on AMD64 FreeBSD 9.x 3.6
Type: Stage: resolved
Components: Tests Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Change socket.close() to ignore ECONNRESET
View: 30319
Assigned To: Nosy List: haypo
Priority: normal Keywords: buildbot

Created on 2017-05-10 12:24 by haypo, last changed 2017-07-04 14:50 by haypo. This issue is now closed.

Messages (4)
msg293408 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-05-10 12:24
See also bpo-30315 (test_ftplib) and bpo-30319 (test_imaplib).

http://buildbot.python.org/all/builders/AMD64%20FreeBSD%209.x%203.6/builds/131/steps/test/logs/stdio

test_connect_with_context (test.test_ssl.SimpleBackgroundTests) ...  server:  new connection from ('127.0.0.1', 53510)
 server: connection cipher is now ('ECDHE-RSA-AES256-SHA', 'TLSv1/SSLv3', 256)
 server: selected protocol is now None
Test server failure:
Traceback (most recent call last):
   File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/test/test_ssl.py", line 1944, in run
    self.close()
   File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/test/test_ssl.py", line 1919, in close
    self.sslconn.close()
   File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/socket.py", line 417, in close
    self._real_close()
   File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 1052, in _real_close
    socket._real_close(self)
   File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/socket.py", line 411, in _real_close
    _ss.close(self)
 ConnectionResetError: [Errno 54] Connection reset by peer
ERROR

...

======================================================================
ERROR: test_connect_with_context (test.test_ssl.SimpleBackgroundTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/test/test_ssl.py", line 1541, in test_connect_with_context
    s.connect(self.server_addr)
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 1093, in connect
    self._real_connect(addr, False)
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 1084, in _real_connect
    self.do_handshake()
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 1061, in do_handshake
    self._sslobj.do_handshake()
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 683, in do_handshake
    self._sslobj.do_handshake()
ConnectionResetError: [Errno 54] Connection reset by peer

----------------------------------------------------------------------
Ran 127 tests in 12.751s

FAILED (errors=1, skipped=7)
test test_ssl failed
msg293824 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-05-17 00:05
SimpleBackgroundTests uses a server running in a different thread, so running locally. The port is binded by support.bind_port(socket, "127.0.0.1").
msg297038 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-06-27 14:18
http://buildbot.python.org/all/builders/AMD64%20FreeBSD%209.x%203.6/builds/137/steps/test/logs/stdio

======================================================================
ERROR: test_connect_with_context (test.test_ssl.SimpleBackgroundTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/test/test_ssl.py", line 1541, in test_connect_with_context
    s.connect(self.server_addr)
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 1093, in connect
    self._real_connect(addr, False)
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 1084, in _real_connect
    self.do_handshake()
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 1061, in do_handshake
    self._sslobj.do_handshake()
  File "/usr/home/buildbot/python/3.6.koobs-freebsd9/build/Lib/ssl.py", line 683, in do_handshake
    self._sslobj.do_handshake()
ConnectionResetError: [Errno 54] Connection reset by peer
msg297661 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-07-04 14:50
Duplicate of bpo-30319.
History
Date User Action Args
2017-07-04 14:54:42haypounlinkissue30319 dependencies
2017-07-04 14:50:02hayposetstatus: open -> closed
superseder: Change socket.close() to ignore ECONNRESET
messages: + msg297661

resolution: duplicate
stage: resolved
2017-06-27 14:18:23hayposetmessages: + msg297038
2017-06-03 22:26:56martin.panterlinkissue30319 dependencies
2017-05-17 00:05:07hayposetmessages: + msg293824
2017-05-10 12:24:06haypocreate