classification
Title: Idle, some Linuxes, cannot position Cursor by mouseclick
Type: behavior Stage:
Components: IDLE Versions: Python 3.1, Python 2.7
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: kbk Nosy List: Sunny0815, dbarabash, gpolo, kbk, michiel.overtoom
Priority: normal Keywords:

Created on 2008-05-28 17:19 by Sunny0815, last changed 2009-04-22 20:05 by gpolo. This issue is now closed.

Messages (10)
msg67460 - (view) Author: Matthias Sommer (Sunny0815) Date: 2008-05-28 17:19
I'm used to be able to position the cursor by clicking on the desired
position. When running Idle (1.2.2 with Python 2.5.2) under Mandriva
Linux 2008 (or under Arch Linux 64 or i686 as well as FaunOS a Arch
based live distro) this does not work.

Running under windows it works, running under Xandros linux on my eee pc
 it works too, so it's not linux specific.

I already asked on the german python ng. There have been reports that it
works too on Suse and Ubuntu. But as of yet no hint where to look to
make it working under Arch oder Mandriva.

Strange enough, i can position the Cursor by Ctrl-clicking.

I tried with a tiny Tk program with a single text field - there the
positioning does work too.

So it seems to be a bug in the distro(s) and regarding only Idle not
Tkinter in total.
msg78639 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2008-12-31 17:42
Can you retry making some small example that demonstrates the problem ?
msg78694 - (view) Author: Matthias Sommer (Sunny0815) Date: 2009-01-01 09:40
Retry is a bit difficult now, sinc I reverted back to Windows after 
getting quite some answers in some places, but none of them really 
helpful.

It happend under Madriva Linux (and some other tested Linuxes). Now I'm 
using Gentoo (this is, IF I'm using Linux). And there it works all fine.

The problem was: Usually one can set the cursorposition in any given 
(gui) text editor by mouse click in the text. Using Madriva, I can 
click, but the cursor is not affected.
msg80325 - (view) Author: Michiel Overtoom (michiel.overtoom) * Date: 2009-01-21 14:09
I experience the same, on FreeBSD 7.0-REL, with tkinter compiled to use
Tk8.5 instead of Tk8.4.  Tkinter compiled for Tk8.4 doesn't have the
problem.

Moving the mouse over the text widget changes the cursor to the I-beam
as expected, but click on text doesn't position the beam at the mouse
position.  It is also impossible to select text with the mouse. 
Selecting text with shift-arrow keys works, however.

The same bug has been reported on the OLPC wiki:

http://dev.laptop.org/ticket/7661
http://wiki.laptop.org/go/User:Rmyers/IDLE_on_the_XO
msg80718 - (view) Author: Darrell Barabash (dbarabash) Date: 2009-01-28 17:39
I'm using Mandriva 2009.0 and can confirm this problem. RMeyers
suggested testing further by loading and running idlelibs/IOBinding.py.

On my Linux system I find that the mouse clicks and selection works fine
when running IOBinding.py. Being that this module appears to be built
upon Tkinter, it would seem that the bug is at a higher level?
msg84320 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-03-28 18:26
I'm downloading Mandriva 2009.0 to hopefully reproduce the problem, but
I'm afraid it won't happen. Apparently people that have this issue also
reproduce it in different platforms, someone said on
http://dev.laptop.org/ticket/7661 that this occurs both on a olpc as
well on his mac.
msg84357 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-03-29 01:35
Whoa, it went better than I expected. It failed on Mandriva just like it
was mentioned, but I still haven't verified what is causing this problem.

And while running IOBinding.py doesn't demonstrate the problem, running
EditorWindow.py does.
msg84400 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-03-29 14:02
Uhm, I have compiled python-trunk in this Mandriva 2009 now and it
works! I didn't change tcl/tk version, just installed the dev packages
in order to compile _tkinter.

I still don't know how what kind of changes were done by Mandriva in
order to achieve this problem, but I believe this is an issue that will
not be solved here.

Given this bug is not so old, I expect some of the initial posters to
still be around. Any chance you can ask someone at Sugar to try
compiling python from source and test if the bug persists ?
msg84418 - (view) Author: Matthias Sommer (Sunny0815) Date: 2009-03-29 17:43
Guilherme Polo wrote:

I am the originator of this issue, and I'm back here. So I can add some text.

I remember having read comments on this issue striking on other linuxes 
too. But I do not remember anymore what distibutions this were.

I switched my Python development to windows (or to be true, I did not 
switch from windows to linux as intended at the office).

At home I switched the Distribution first to Gentoo and lately to 
Ubuntu. These both work fine.
So I am out here in fact.

Regards
Matthias Sommer
msg86325 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-04-22 20:05
Closing as won't fix since there is nothing to fix on Python side, not
from what I have noticed at least.

Mandriva 2009 and Sugar (and other places with this problem) should
check how they got IDLE to act like that, and could try compiling python
from source like I did to verify if the problem goes away.
History
Date User Action Args
2009-04-22 20:05:36gpolosetstatus: open -> closed
resolution: wont fix
messages: + msg86325
2009-03-29 17:43:12Sunny0815setmessages: + msg84418
2009-03-29 14:02:45gpolosetmessages: + msg84400
2009-03-29 01:35:37gpolosetmessages: + msg84357
versions: + Python 3.1, Python 2.7, - Python 2.5
2009-03-28 18:26:14gpolosetmessages: + msg84320
2009-01-28 17:39:34dbarabashsetnosy: + dbarabash
messages: + msg80718
2009-01-21 14:09:55michiel.overtoomsetnosy: + michiel.overtoom
messages: + msg80325
2009-01-01 09:40:28Sunny0815setmessages: + msg78694
2008-12-31 17:42:14gpolosetnosy: + gpolo
messages: + msg78639
2008-05-28 21:31:41georg.brandlsetassignee: kbk
nosy: + kbk
2008-05-28 17:19:39Sunny0815create