classification
Title: Windows: test_platform.test_architecture_via_symlink() regression
Type: Stage: resolved
Components: Windows Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: steve.dower Nosy List: paul.moore, python-dev, steve.dower, tim.golden, vstinner, zach.ware
Priority: normal Keywords:

Created on 2016-09-10 08:13 by vstinner, last changed 2016-09-10 19:25 by python-dev. This issue is now closed.

Messages (7)
msg275596 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-09-10 08:13
It looks like test_platform started to fail on AMD64 Windows10 3.x between build 1456 (success) and 1458 (failure, 1457 was interrupted or something like that).

The regression may be related to the issue #27932, change 31b7eaff5588.

http://buildbot.python.org/all/builders/AMD64%20Windows10%203.x/builds/1458/steps/test/logs/stdio

======================================================================
FAIL: test_architecture_via_symlink (test.test_platform.PlatformTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\buildarea\3.x.bolen-windows10\build\lib\test\test_platform.py", line 33, in test_architecture_via_symlink
    self.assertEqual(get(real), get(link))
AssertionError: Tuples differ: (b"('64bit', 'WindowsPE')\r\n", None) != (b'', None)

First differing element 0:
b"('64bit', 'WindowsPE')\r\n"
b''

- (b"('64bit', 'WindowsPE')\r\n", None)
+ (b'', None)

----------------------------------------------------------------------
msg275651 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-09-10 16:16
http://buildbot.python.org/all/builders/AMD64%20Windows8%203.x/builds/2553/steps/test/logs/stdio

test_architecture_via_symlink (test.test_platform.PlatformTest) ... Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "D:\buildarea\3.x.bolen-windows8\build\lib\platform.py", line 501, in <module>
    import ctypes
  File "D:\buildarea\3.x.bolen-windows8\build\lib\ctypes\__init__.py", line 7, in <module>
    from _ctypes import Union, Structure, Array
ModuleNotFoundError: No module named '_ctypes'
FAIL
msg275659 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-09-10 17:19
That's strange, win32 should always have _ctypes available. I'll try and take a look later today
msg275661 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-09-10 17:27
Though ctypes here is incorrect anyway. I really ought to rewrite it into the winapi module.

I'll revert the memory leak fix and fix the tests for b1, then look at converting it into a native function for b2.
msg275663 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2016-09-10 17:48
> Though ctypes here is incorrect anyway. I really ought to rewrite it into the winapi module.

I agree, it's much better to avoid ctypes in the stdlib.
msg275682 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-09-10 19:24
This bug is entirely because _ctypes cannot be found when we launch from the symlink without also setting PYTHONPATH.

I've already removed the import of _ctypes, but I'll also set PYTHONPATH in the test as there's no reason to require only builtins here.
msg275683 - (view) Author: Roundup Robot (python-dev) Date: 2016-09-10 19:25
New changeset 94563ec74e1d by Steve Dower in branch '3.5':
Closes #28059: Fixes test_platform to set PYTHONPATH for .pyd files
https://hg.python.org/cpython/rev/94563ec74e1d

New changeset 3ec4feb52a5b by Steve Dower in branch 'default':
Closes #28059: Fixes test_platform to set PYTHONPATH for .pyd files
https://hg.python.org/cpython/rev/3ec4feb52a5b
History
Date User Action Args
2016-09-10 19:25:26python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg275683

resolution: fixed
stage: resolved
2016-09-10 19:24:05steve.dowersetmessages: + msg275682
2016-09-10 17:48:26vstinnersetmessages: + msg275663
2016-09-10 17:27:10steve.dowersetmessages: + msg275661
2016-09-10 17:19:27steve.dowersetassignee: steve.dower
messages: + msg275659
2016-09-10 16:16:45vstinnersetmessages: + msg275651
2016-09-10 08:13:18vstinnercreate