classification
Title: Deprecate building with bundled copy of libffi on non-Darwin POSIX platforms
Type: enhancement Stage: resolved
Components: Build, ctypes Versions: Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Arfrever, berker.peksag, chris.jerdonek, doko, fabiovmp, gustavotemple, koobs, lemburg, meador.inge, ned.deily, python-dev, r.david.murray, steve.dower, tim.golden, xdegaye, yan12125, zach.ware
Priority: normal Keywords: patch

Created on 2016-09-06 17:56 by zach.ware, last changed 2016-09-10 00:01 by python-dev. This issue is now closed.

Files
File name Uploaded Description Edit
deprecate_bundled_libffi.diff zach.ware, 2016-09-06 17:56 review
issue27976.diff zach.ware, 2016-09-08 00:04 review
Messages (6)
msg274576 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2016-09-06 17:56
Nosy list copied from #23085.

Here's a patch that deprecates building _ctypes with the bundled copy of libffi (Modules/_ctypes/libffi/).  The default on all platforms (other than Windows) is now to use a system copy of libffi; use the '--without-system-ffi' flag to ./configure to use the bundled copy.  On non-Darwin platforms, a warning will be emitted noting that Modules/_ctypes/libffi will not be distributed with 3.7.
msg274627 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-09-06 20:56
+1, thanks for working on this!

Two questions:

1. Should we check the system version of libffi and warn users (and probably use the bundled version for now) if it was older than 3.1?

2. I know this isn't directly a user-facing feature, but should we add a short note to Doc/whatsnew/3.6.rst? (we can probably mention that most of the Linux distributions already use --with-system-ffi.)
msg274628 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2016-09-06 21:06
I don't think it's worthwhile to do a version check and warning, especially since we'll be removing the bundled version in 3.7.  A docs note is worthwhile, though, I'll attach a new patch shortly.
msg274761 - (view) Author: Chih-Hsuan Yen (yan12125) * Date: 2016-09-07 05:22
That's great! issue26942 can be closed after this change is landed. It's caused by a libffi bug on Android.
msg274926 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2016-09-08 00:04
Finally got a new patch created.  After talking it over with Ned yesterday, this patch makes sure that nothing changes on OSX.
msg275504 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-09-10 00:01
New changeset 3e02187e50df by Zachary Ware in branch 'default':
Closes #27976: Deprecate bundled full copy of libffi
https://hg.python.org/cpython/rev/3e02187e50df
History
Date User Action Args
2016-09-10 00:01:35python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg275504

resolution: fixed
stage: commit review -> resolved
2016-09-08 00:04:56zach.waresetfiles: + issue27976.diff

messages: + msg274926
2016-09-07 05:22:54yan12125setmessages: + msg274761
2016-09-06 21:06:26zach.waresetmessages: + msg274628
2016-09-06 20:56:28berker.peksagsetmessages: + msg274627
stage: patch review -> commit review
2016-09-06 18:54:54zach.warelinkissue27979 dependencies
2016-09-06 17:58:36zach.warelinkissue23085 superseder
2016-09-06 17:57:39zach.waresetcomponents: + ctypes
2016-09-06 17:56:22zach.warecreate