classification
Title: Distutils tests are broken in 3.4
Type: crash Stage: needs patch
Components: Tests Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: jaraco Nosy List: jaraco, larry, martin.panter, python-dev, zach.ware
Priority: release blocker Keywords: 3.4regression

Created on 2016-09-05 23:47 by larry, last changed 2016-09-06 02:36 by jaraco. This issue is now closed.

Messages (7)
msg274472 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2016-09-05 23:47
3.4.5 shipped with a working test suite.  Since the release of 3.4.5 somebody broke test_distutils in the 3.4 branch.  It needs to be fixed.

jason.coombs: AFAICT you were the last person to touch it.  Are you the one who broke it?


 % ./python -m test test_distutils
[1/1] test_distutils
test test_distutils crashed -- Traceback (most recent call last):
  File "/home/larry/src/python/broke34/Lib/test/regrtest.py", line 1279, in runtest_inner
    test_runner()
  File "/home/larry/src/python/broke34/Lib/test/test_distutils.py", line 13, in test_main
    test.support.run_unittest(distutils.tests.test_suite())
  File "/home/larry/src/python/broke34/Lib/distutils/tests/__init__.py", line 31, in test_suite
    suite.addTest(module.test_suite())
AttributeError: 'module' object has no attribute 'test_suite'

1 test failed:
    test_distutils
msg274490 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2016-09-06 01:17
Probably related to the <https://hg.python.org/cpython/log/3.4/Lib/distutils/tests/test_filelist.py> changes and Issue 12885. Most of the changes were probably reverted from 3.4 in revision e82b995d1a5c, but it looks like we also need to fully revert cc86e9e102e8 to add test_suite() back.

The foolproof thing would be to copy the old working version of these files, review the diff, and check it back in as a new commit.
msg274496 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2016-09-06 02:16
Sorry you've had to spend any time on this. I'll get it corrected immediately.
msg274500 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2016-09-06 02:28
I invoked `hg revert --all -r 675e20c38fdac6` at the 3.4 head, and that effectively reverted everything to its state prior to the commits.
msg274502 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-09-06 02:29
New changeset 556a11c11edd by Jason R. Coombs in branch '3.4':
Issue #27960: Revert state to 675e20c38fdac6, backing out all changes by developed for Issue #12885.
https://hg.python.org/cpython/rev/556a11c11edd

New changeset b442744d2d22 by Jason R. Coombs in branch '3.5':
Issue #27960: Merge with 3.4
https://hg.python.org/cpython/rev/b442744d2d22

New changeset 7cec1a1d6950 by Jason R. Coombs in branch 'default':
Issue #27960: Merge with 3.5
https://hg.python.org/cpython/rev/7cec1a1d6950
msg274503 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2016-09-06 02:32
I believe this is fixed now. I'll be testing locally, but please don't hesitate to let me know if you find otherwise.
msg274505 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2016-09-06 02:36
Confirmed working here now.

$ hg id -i
556a11c11edd
$ ./python.exe -m test test_distutils
[1/1] test_distutils
1 test OK.
History
Date User Action Args
2016-09-06 02:36:44jaracosetmessages: + msg274505
2016-09-06 02:32:59jaracosetstatus: open -> closed
resolution: fixed
messages: + msg274503
2016-09-06 02:29:57python-devsetnosy: + python-dev
messages: + msg274502
2016-09-06 02:28:17jaracosetmessages: + msg274500
2016-09-06 02:16:59jaracosetmessages: + msg274496
2016-09-06 01:17:47martin.pantersetnosy: + martin.panter
messages: + msg274490
2016-09-05 23:47:31larrycreate