classification
Title: Python Windows x86-64 embeddable zip file missing module encodings
Type: Stage: resolved
Components: Installation Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: steve.dower Nosy List: python-dev, steve.dower, tds333
Priority: normal Keywords:

Created on 2016-05-18 07:43 by tds333, last changed 2016-05-19 19:10 by steve.dower. This issue is now closed.

Messages (4)
msg265818 - (view) Author: Wolfgang Langner (tds333) * Date: 2016-05-18 07:43
Tried to extract Windows x86-64 embeddable zip file and execute it.
But following error happened (3.6.0a1):

Fatal Python error: Py_Initialize: unable to load the file system codec
ImportError: No module named 'encodings'

Current thread 0x000017c4 (most recent call first):

----

Also tried release version 3.5.1, this version works fine.
msg265874 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-05-19 16:35
The "python35.zip" file contains the standard library and it needs to be renamed "python36.zip".

Apparently I hardcoded this somewhere instead of inferring it from the current version... I'll fix.
msg265875 - (view) Author: Wolfgang Langner (tds333) * Date: 2016-05-19 16:38
Yes this is the cause. If it is renamed to python36.zip everything works fine.
For the test I have only extracted the distributed zip and executed python.exe. Had not looked further into the issue. So only the simple report something did not work.

Thanks for looking at it and fixing.
msg265884 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-05-19 19:10
New changeset 12cb81e90479 by Steve Dower in branch '3.5':
Issue #27053: Updates make_zip.py to correctly generate library ZIP file.
https://hg.python.org/cpython/rev/12cb81e90479

New changeset a6473f7a8c55 by Steve Dower in branch 'default':
Issue #27053: Updates make_zip.py to correctly generate library ZIP file.
https://hg.python.org/cpython/rev/a6473f7a8c55
History
Date User Action Args
2016-05-19 19:10:56steve.dowersetstatus: open -> closed
resolution: fixed
stage: resolved
2016-05-19 19:10:46python-devsetnosy: + python-dev
messages: + msg265884
2016-05-19 16:38:53tds333setmessages: + msg265875
2016-05-19 16:35:03steve.dowersetassignee: steve.dower
messages: + msg265874
versions: + Python 3.5
2016-05-18 07:43:11tds333create