classification
Title: trace CLI doesn't respect -s option
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: belopolsky, berker.peksag
Priority: normal Keywords: patch

Created on 2016-04-21 14:28 by berker.peksag, last changed 2018-08-11 06:29 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
trace_cli_cummary.diff berker.peksag, 2016-04-21 14:28 review
Pull Requests
URL Status Linked Edit
PR 8664 merged berker.peksag, 2018-08-03 21:27
PR 8732 merged miss-islington, 2018-08-11 06:16
Messages (3)
msg263921 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-04-21 14:28
I noticed this while triaging issue 9317. Using traceme.py from that issue,

    $ ./python -m trace -c -s traceme.py

returns nothing. It seems like it's a regression caused by https://github.com/python/cpython/commit/17e5da46a733a1a05072a277bc81ffa885f0c204

With trace_cli_summary.diff applied:

    $ ./python -m trace -c -s traceme.py
    lines   cov%   module   (path)
        1   100%   trace   (/home/berker/projects/cpython/default/Lib/trace.py)
        6   100%   traceme   (traceme.py)

trace_cli_summary.diff also fixes issue 10541.
msg323402 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2018-08-11 06:15
New changeset c8b0dbc4928a1fe4bd5abebd810b6849374c7af3 by Berker Peksag in branch 'master':
bpo-26818: Add a test to make sure the bug is fixed (GH-8664)
https://github.com/python/cpython/commit/c8b0dbc4928a1fe4bd5abebd810b6849374c7af3
msg323404 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2018-08-11 06:28
New changeset 8fc21c80af73226de875886132e0c32a4ffb32c5 by Berker Peksag (Miss Islington (bot)) in branch '3.7':
bpo-26818: Add a test to make sure the bug is fixed (GH-8664)
https://github.com/python/cpython/commit/8fc21c80af73226de875886132e0c32a4ffb32c5
History
Date User Action Args
2018-08-11 06:29:00berker.peksagsetstatus: open -> closed
stage: patch review -> resolved
resolution: fixed
versions: + Python 3.7, Python 3.8, - Python 3.5, Python 3.6
2018-08-11 06:28:37berker.peksagsetmessages: + msg323404
2018-08-11 06:16:03miss-islingtonsetpull_requests: + pull_request8218
2018-08-11 06:15:46berker.peksagsetmessages: + msg323402
2018-08-03 21:27:11berker.peksagsetpull_requests: + pull_request8159
2016-04-21 14:28:39berker.peksagcreate