classification
Title: libmpdec: disable /W4 warning (non-standard dllimport behavior)
Type: compile error Stage: resolved
Components: Extension Modules Versions: Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: skrah Nosy List: Alexander Riccio, python-dev, skrah
Priority: normal Keywords:

Created on 2016-01-17 11:27 by skrah, last changed 2016-01-18 11:43 by Alexander Riccio. This issue is now closed.

Messages (5)
msg258461 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2016-01-17 11:27
See: #25878
msg258462 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-01-17 11:29
New changeset df78978dacab by Stefan Krah in branch 'default':
Issue #26139: libmpdec: disable /W4 warning (non-standard dllimport behavior).
https://hg.python.org/cpython/rev/df78978dacab
msg258487 - (view) Author: Alexander Riccio (Alexander Riccio) * Date: 2016-01-18 00:09
#pragma warning(disable : 4232) is almost always NOT what you want. 

See: http://www.viva64.com/en/k/0048/
msg258518 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2016-01-18 11:39
This is *exactly* what I want.  As the sole author of libmpdec I *know*
that the broken dllimport behavior cannot affect anything in memory.c,
since there are no function pointer comparisons.

Please stop educating us.
msg258519 - (view) Author: Alexander Riccio (Alexander Riccio) * Date: 2016-01-18 11:43
> Please stop educating us.

Sorry, not what was intended! Tone transmits poorly.
History
Date User Action Args
2016-01-18 11:43:22Alexander Ricciosetmessages: + msg258519
2016-01-18 11:39:14skrahsetmessages: + msg258518
2016-01-18 00:09:01Alexander Ricciosetnosy: + Alexander Riccio
messages: + msg258487
2016-01-17 11:32:23skrahsetstatus: open -> closed
resolution: fixed
stage: resolved
2016-01-17 11:29:06python-devsetnosy: + python-dev
messages: + msg258462
2016-01-17 11:27:07skrahcreate