classification
Title: test_eintr.test_os_open hangs under Xcode 7
Type: behavior Stage: resolved
Components: macOS Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: brett.cannon Nosy List: brett.cannon, martin.panter, ned.deily, python-dev, ronaldoussoren, vstinner
Priority: normal Keywords:

Created on 2015-09-25 19:41 by brett.cannon, last changed 2019-05-21 21:24 by ned.deily. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 10449 taleinat, 2018-12-25 03:11
PR 10449 taleinat, 2018-12-25 03:11
Messages (14)
msg251597 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-09-25 19:41
Specifically:
Apple LLVM version 7.0.0 (clang-700.0.72)
Target: x86_64-apple-darwin14.5.0
Thread model: posix

I'm assuming this is a Mac issue since none of the buildbots are having a similar issue.
msg251647 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-09-26 13:26
Brett, was this on OS X 10.10.x or a 10.11 pre-release?  test_eintr does not fail fail for me on either using the most recent Xcode 7.
msg251650 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-09-26 15:13
It is 10.10, but apparently a reboot fixed it (software, am I right? =/ ).
msg253084 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-10-16 18:22
This is still an intermittent problem for me. Maybe it's related to issue #25122 ?
msg253099 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2015-10-16 21:06
Hi Brett, if you are motivated, you can try the C program that I wrote to reproduce the bug on FreeBSD. It's attached to #25122. If the C program hangs too, it would mean that Darwin has also a bug (same bug??) in its code to handle signals in the code handling FIFO devices.

Or you can just add a skip mentioning this issue.

On my FreeBSD VM, it took a few minutes and multiples instances of the C program to reproduce the bug. On physical machines, other reported that a seconds and a single instance is enough. Well, see the FreeBSD bug report for more information ;-)
msg253101 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-10-16 21:59
I can't get your testing program to compile, Victor, so if I run into it again I will add a skip to the test (harder to detect that it's the same test since test_eintr runs another test suite as if it's a single test).
msg256280 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2015-12-12 11:54
The Yosemite ICC 3.5 buildbot seems to be intermittently hanging test_os_open() and test_open(). Currently it shows five builds. Build 396 hung at test_os_open(); build 400 hung at test_open(), and the other three passed.

http://buildbot.python.org/all/builders/x86-64%20Yosemite%20ICC%20Debug%203.5

Slave information
Buildbot-Slave 0.8.12
OSX 10.10.3 (Yosemite) Mac Mini VMWare VM 2x2.86 GHz 8GB
msg256315 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-12-13 04:24
I'm still getting the occasional hang for this so I'm going to skip the test under OS X.
msg256337 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2015-12-13 20:29
> I'm still getting the occasional hang for this so I'm going to skip the test under OS X.

Go ahead. I'm not interested to analyze bugs of closed source kernels.
msg257155 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2015-12-29 01:23
New changeset 7fc1296d1acf by Brett Cannon in branch 'default':
Issue #25234: Skip test_eintr.test_os_open under OS X.
https://hg.python.org/cpython/rev/7fc1296d1acf
msg258351 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2016-01-16 04:09
Brett, do you think you should also skip test_open()? The same buildbot recently failed again in that method.
msg258399 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2016-01-16 18:15
Sure, that test can be skipped as well if it is hanging.
msg258848 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-01-22 23:56
New changeset 9d65a195246b by Brett Cannon in branch 'default':
Issue #25234: Skip test_eintr.test_open() under OS X to avoid hanging
https://hg.python.org/cpython/rev/9d65a195246b
msg259150 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-01-28 17:15
New changeset ddce15b21c21 by Victor Stinner in branch '3.5':
Backport fixes on test_eintr
https://hg.python.org/cpython/rev/ddce15b21c21
History
Date User Action Args
2019-05-21 21:24:57ned.deilysetpull_requests: - pull_request13383
2019-05-21 20:39:08mbussonnsetpull_requests: + pull_request13383
2018-12-25 03:12:08taleinatsetpull_requests: + pull_request10549
2018-12-25 03:11:57taleinatsetpull_requests: + pull_request10548
2016-01-28 17:15:12python-devsetmessages: + msg259150
2016-01-22 23:56:16brett.cannonsetstatus: open -> closed
2016-01-22 23:56:04python-devsetmessages: + msg258848
2016-01-16 18:15:34brett.cannonsetstatus: closed -> open

messages: + msg258399
2016-01-16 04:09:45martin.pantersetmessages: + msg258351
2015-12-29 01:23:58brett.cannonsetstatus: open -> closed
resolution: fixed
stage: resolved
2015-12-29 01:23:46python-devsetnosy: + python-dev
messages: + msg257155
2015-12-13 20:29:06vstinnersetmessages: + msg256337
2015-12-13 04:24:54brett.cannonsetassignee: brett.cannon
messages: + msg256315
2015-12-12 11:54:32martin.pantersetnosy: + martin.panter

messages: + msg256280
versions: + Python 3.5
2015-10-16 21:59:10brett.cannonsetmessages: + msg253101
2015-10-16 21:06:28vstinnersetmessages: + msg253099
2015-10-16 18:22:27brett.cannonsetstatus: closed -> open

nosy: + vstinner
messages: + msg253084

resolution: not a bug -> (no value)
2015-09-26 15:13:37brett.cannonsetstatus: open -> closed
resolution: not a bug
messages: + msg251650
2015-09-26 13:26:02ned.deilysetmessages: + msg251647
title: test_einter.test_os_open hangs under Xcode 7 -> test_eintr.test_os_open hangs under Xcode 7
2015-09-25 19:41:19brett.cannoncreate