classification
Title: Backports Arch Linux support for platform.linux_distribution()
Type: Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: platform.linux_distribution() returns empty value on Archlinux and python 2.7
View: 20454
Assigned To: Nosy List: Nathan Ringo, berker.peksag
Priority: normal Keywords: patch

Created on 2015-06-06 20:04 by Nathan Ringo, last changed 2015-06-06 20:14 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
support_dist_arch.patch Nathan Ringo, 2015-06-06 20:04 review
Messages (2)
msg244925 - (view) Author: Nathan Ringo (Nathan Ringo) * Date: 2015-06-06 20:04
On Arch Linux, running `python2 -c "import platform; print platform.linux_distribution()"'

Before patch: ('', '', '')
After patch: ('arch', 'Arch', 'Linux')

This matches the Python 3 behavior:
`python3 -c "import platform; print(platform.linux_distribution())"'

('arch', 'Arch', 'Linux')
msg244926 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2015-06-06 20:14
Thanks for the report. This is a duplicate of issue 20454.
History
Date User Action Args
2015-06-06 20:14:47berker.peksagsetstatus: open -> closed

superseder: platform.linux_distribution() returns empty value on Archlinux and python 2.7

nosy: + berker.peksag
messages: + msg244926
resolution: duplicate
stage: resolved
2015-06-06 20:04:55Nathan Ringocreate