classification
Title: platform.linux_distribution() returns empty value on Archlinux and python 2.7
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, Nathan Ringo, fmoreau, ha034, lemburg, petr.viktorin, r.david.murray
Priority: normal Keywords:

Created on 2014-01-31 11:02 by fmoreau, last changed 2018-05-25 17:20 by petr.viktorin. This issue is now closed.

Messages (7)
msg209764 - (view) Author: Francis Moreau (fmoreau) Date: 2014-01-31 11:02
On Archlinux:

$ python2.7 -c 'import platform; print(platform.linux_distribution())'
('', '', '')

This is because Archlinux is not part of the '_supported_dists' list.

Could Archlinux be added to this list ?

Thanks.
msg237626 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2015-03-09 09:53
Can Archlinux be added to _supported_dists as requested in msg209764, I've no understanding of the criteria involved here?
msg241212 - (view) Author: (ha034) Date: 2015-04-16 11:49
Hey guys,

Just add:

    if os.path.exists('/etc/arch-release'):
        distname = 'arch'

in "_dist_try_harder"

then replace the old list with this one:

_supported_dists = (
    'SuSE', 'debian', 'fedora', 'redhat', 'centos',
    'mandrake', 'mandriva', 'rocks', 'slackware', 'yellowdog', 'gentoo',
    'UnitedLinux', 'turbolinux', 'arch')

And that's it, it works.
msg241280 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2015-04-16 21:59
Since the direction we are heading seems to toward deprecating linux_distribution (see http://bugs.python.org/issue1322#msg207427), I think this issue should be closed.
msg244927 - (view) Author: Nathan Ringo (Nathan Ringo) * Date: 2015-06-06 20:24
The problem is, existing software (Ansible) relies on linux_distribution()
msg317687 - (view) Author: Petr Viktorin (petr.viktorin) * (Python committer) Date: 2018-05-25 17:17
linux_distribution is removed in Python 3.7.
Closing.
msg317689 - (view) Author: Petr Viktorin (petr.viktorin) * (Python committer) Date: 2018-05-25 17:20
Er, sorry, I meant in 3.8.
History
Date User Action Args
2018-05-25 17:20:40petr.viktorinsetmessages: + msg317689
2018-05-25 17:17:01petr.viktorinsetstatus: open -> closed

nosy: + petr.viktorin
messages: + msg317687

resolution: out of date
stage: resolved
2016-01-04 20:36:37eric.smithlinkissue26008 superseder
2015-06-06 20:24:17Nathan Ringosetmessages: + msg244927
2015-06-06 20:15:16berker.peksagsetnosy: + Nathan Ringo
2015-06-06 20:14:47berker.peksaglinkissue24399 superseder
2015-04-16 21:59:41r.david.murraysetnosy: + r.david.murray
messages: + msg241280
2015-04-16 11:49:42ha034setnosy: + ha034
messages: + msg241212
2015-03-09 09:53:59BreamoreBoysetnosy: + BreamoreBoy
messages: + msg237626
2014-01-31 11:03:13fmoreausettype: behavior
2014-01-31 11:02:45fmoreaucreate