classification
Title: Remove a now-unnecessary workaround from importlib._bootstrap.
Type: behavior Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: eric.snow Nosy List: Arfrever, brett.cannon, dstufft, eric.snow, larry, ncoghlan, python-dev
Priority: normal Keywords: patch

Created on 2015-05-28 22:34 by eric.snow, last changed 2016-09-09 20:42 by eric.snow. This issue is now closed.

Files
File name Uploaded Description Edit
issue24320-remove-hack.diff eric.snow, 2015-06-02 23:07 review
Messages (9)
msg244350 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2015-05-28 22:34
In issue #23911 I worked around a bug [1] in pkg_resources (setuptools) which caused test_venv to fail when I split out importlib._bootstrap_external.  That bug has now been fixed so we just(?) need to update the version of pip we're bundling and remove the hack I put in as a workaround (see msg242440).

[1] https://bitbucket.org/pypa/setuptools/issue/378
msg244351 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2015-05-28 22:36
Would we be okay fixing this in 3.5 as well?  I ask because I'm not familiar with the constraints we have on what pip is bundled.
msg244454 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2015-05-30 09:58
Donald updated 3.5 to pip 7 for the 1st beta, so the relevant fix may have already been included.
msg244681 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2015-06-02 17:39
https://hg.python.org/cpython/rev/5c4ba50f6a57

I'll see if that does it.

@Larry, would you be opposed to dropping the hack for beta 3?  That would mean just deleting the last 2 lines in Lib/importlib/_bootstrap_external.py.
msg244695 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2015-06-02 21:49
Sounds okay in theory.  Is the bug in question now tested in our regression suite?
msg244697 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2015-06-02 21:51
Yep. test_venv failures is how I found the problem in the first place.
msg244699 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2015-06-02 21:51
Then you may fire when ready.
msg244710 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2015-06-02 23:07
Hmm.  Looks like the fix in setuptools/pkg_resources is 17.0. [1]  The bundled pip to which we just updated is 7.0.3, which appears to bundle pkg_resources 15.0. [2]  So unless I've misunderstood, the hack will have to linger for a bit longer.

Here's a patch for when we get there.

[1] https://bitbucket.org/pypa/setuptools/commits/tag/17.0
[2] https://github.com/pypa/pip/blob/7.0.3/pip/_vendor/README.rst
msg275431 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-09-09 20:41
New changeset 821663556d87 by Eric Snow in branch 'default':
Issue #24320: Drop an old setuptools-induced hack.
https://hg.python.org/cpython/rev/821663556d87
History
Date User Action Args
2016-09-09 20:42:21eric.snowsetstatus: open -> closed
type: behavior
resolution: fixed
stage: patch review -> resolved
2016-09-09 20:41:47python-devsetnosy: + python-dev
messages: + msg275431
2015-06-03 00:52:31Arfreversetnosy: + Arfrever
2015-06-02 23:07:50eric.snowsetfiles: + issue24320-remove-hack.diff

nosy: + dstufft
messages: + msg244710

keywords: + patch
stage: needs patch -> patch review
2015-06-02 21:51:54larrysetmessages: + msg244699
2015-06-02 21:51:25eric.snowsetmessages: + msg244697
2015-06-02 21:50:00larrysetmessages: + msg244695
2015-06-02 17:39:58eric.snowsetmessages: + msg244681
2015-05-30 09:58:57ncoghlansetmessages: + msg244454
2015-05-28 22:41:03serhiy.storchakasetnosy: + larry
2015-05-28 22:36:07eric.snowsetmessages: + msg244351
2015-05-28 22:34:56eric.snowcreate