This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: IDLE crashes when I press ^ caret key
Type: behavior Stage: resolved
Components: macOS Versions: Python 3.4
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: kbk, magnus.forsberg, ned.deily, roger.serwy, ronaldoussoren, terry.reedy
Priority: normal Keywords:

Created on 2015-05-12 19:05 by magnus.forsberg, last changed 2022-04-11 14:58 by admin. This issue is now closed.

Messages (8)
msg242990 - (view) Author: (magnus.forsberg) Date: 2015-05-12 19:05
Every time I press the ^ key, IDLE crashes. I've tried this with two different keyboards with the same result.
I use IDLE 3.4.3 with Mac OS X 10.10.3.
msg242997 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-05-12 19:22
If you are using a Python 3.4.3 from a installer for OS X or have built your own, have you installed the latest ActiveTcl 8.5.x as described here?

If not, you should have received a warning when you launched IDLE.
msg243011 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2015-05-12 20:55
Does not happen on Windows. Please start Idle with "python -m idlelib" in a console and report any error traceback you see.  Replace 'python' with 'python3' or 'py -3' as needed to start 3.x.  (I am not familiar with osx incantation.)
msg243012 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-05-12 20:59
This is undoubtedly a crash in Tk, not in Python itself, so there won't be any Python traceback.
msg243013 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2015-05-12 21:05
At least on Windows, tk errors usually result in TclError with a message that is sometimes helpful.
msg243014 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-05-12 21:11
Unless I'm very much mistaken, this is another instance of the old Cocoa Tk problem documented here ( and referred to in  It's not like a normal TclError in that it causes the embedded Tcl interpreter used by Python to hard crash with no chance of recovery.  This is why we strongly recommend people not use older versions of Cocoa Tk as, unfortunately, are still shipped by Apple with the latest versions of OS X.  The problem has been fixed in more recent versions of Cocoa Tk such as those shipped by ActiveState and which the installer will use if installed (and will warn about if not installed).
msg243023 - (view) Author: (magnus.forsberg) Date: 2015-05-12 21:59
Thanks for your replies! There is a warning about Tcl/Tk: 
">>> WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable.
Visit for current information."
msg243024 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-05-12 22:10
Thanks!  I'm going to assume then that installing a current ActiveTcl 8.5.x will fix the problem for you.
Date User Action Args
2022-04-11 14:58:16adminsetgithub: 68358
2017-09-15 12:57:29terry.reedylinkissue31438 superseder
2017-09-15 12:54:27terry.reedysetcomponents: - IDLE
title: IDLE crashes when I press ^ key -> IDLE crashes when I press ^ caret key
2017-09-15 12:52:11terry.reedylinkissue29826 superseder
2017-09-15 12:51:43terry.reedylinkissue27804 superseder
2015-05-12 22:10:33ned.deilysetstatus: open -> closed
resolution: third party
messages: + msg243024

stage: resolved
2015-05-12 21:59:11magnus.forsbergsetmessages: + msg243023
2015-05-12 21:11:24ned.deilysetmessages: + msg243014
2015-05-12 21:05:00terry.reedysetmessages: + msg243013
2015-05-12 20:59:28ned.deilysetmessages: + msg243012
2015-05-12 20:55:12terry.reedysettype: crash -> behavior
messages: + msg243011
components: + macOS
2015-05-12 19:22:21ned.deilysetmessages: + msg242997
2015-05-12 19:14:52serhiy.storchakasetnosy: + terry.reedy, kbk, ronaldoussoren, ned.deily, roger.serwy
2015-05-12 19:05:39magnus.forsbergcreate