classification
Title: Mac Apple tcl/tk crashes program when caret ^ character typed in IDLE or tkinter
Type: crash Stage: resolved
Components: macOS Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE crashes when I press ^ caret key
View: 24170
Assigned To: Nosy List: karakoyun, ned.deily, r.david.murray, ronaldoussoren, terry.reedy
Priority: normal Keywords:

Created on 2017-09-13 00:08 by karakoyun, last changed 2017-09-16 16:55 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
IDLE 3 crash error log.rtf karakoyun, 2017-09-13 00:08 Example error log generated by IDLE 3 crash
Messages (11)
msg302012 - (view) Author: ALPER PAKSOY (karakoyun) Date: 2017-09-13 00:08
IDLE 3 crashes and quits whenever I type the caret (^) character in the editor. I have to copy and paste the caret character into the IDLE editor whenever I have to use the caret character. I have the IDLE 3.6.2 running on macOS Sierra (v10.12.6) on mid-2011 27" iMac. Attached is an example  error log generated when IDLE 3 crashes after the typing of the caret character.
msg302026 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2017-09-13 01:26
Have you followed the instructions on this page?:

https://www.python.org/download/mac/tcltk/
msg302031 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-13 04:52
In the future, please upload plain text.  I am fairly certain that this is a duplicate of previous issues about Apple's buggy tcl/tk causing crashes  that bypass Python's error reporting.
msg302080 - (view) Author: ALPER PAKSOY (karakoyun) Date: 2017-09-13 15:13
I downloaded and installed TCL 8.6.6.8606 and restarted my computer. I verified that the new version was installed. Unfortunately the problem has not been solved. Thank you.

Alper
msg302135 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-14 01:48
Ned, is 3.6.2 tkinter on Mac supposed to work with tcl/tk 8.6.6?
msg302136 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-14 02:27
If your installed Python with the 64/32 Mac installer from python.org, follow the instruction, on the link given, to install Active 8.5.18 and *not* 8.6.  I believe the issue is that the _tkinter binary is compiled to work with 8.5, not 8.6.

If you used any other installer, talk with its providers.
msg302194 - (view) Author: ALPER PAKSOY (karakoyun) Date: 2017-09-14 18:22
Problem has been solved after installation of ActiveTcl 8.5.18.0 from ActiveState's web site as per Terry’s recommendations and, then, reinstallation of Python 3.6.2 package from python.org. However, there were many (mis)steps per my ignorance and laziness in between. Thank you very much for all the help!

Noteworthy case notes:

1. The previously installed IDLE 3.6.2 as part of the Python 3.6.2 package continued crashing whenever I entered the caret character after the installation of ActiveTcl 8.5.18.0. I noticed that the IDLE’s Tk version showed 8.5.9 even after I installed, as recommended, ActiveTcl 8.5.18.0, and rebooted my computer. Note that the “info patchlevel” script I executed within tclsh had started returning “8.5.18” instead of “8.5.9” after the installation of ActiveTcl 8.5.18.0.

2. I could not find a way to make the existing Python / IDLE 3.6.2 installation recognise ActiveTcl 8.5.18.0 as the IDLE’s Tk version kept showing 8.5.9. Therefore, I  reinstalled the Python 3.6.2 package downloaded from python.org. The package made the installation to a new location rather than overwriting the existing Python / IDLE 3.6.2 files.

3. The newly installed IDLE 3.6.2 has been working fine without showing any signs of instability. There are no crashes when I type the caret character. Its Tk version shows 8.5.18 along with the tclsh interpreter. 

4. I removed all the files associated with the “buggy” Python / IDLE 3.6.2 installation via the terminal window in order to prevent any future confusion between the old and new installations.

5. Though I installed ActiveTcl 8.6.6.8606 from ActiveState’s web site in my earlier trials, I don’t think I was able to fully test whether this latest Tcl really works with Python / IDLE 3.6.2 or not. After installing ActiveTcl 8.6.6.8606, the “info patchlevel” I executed within tchlsh started returning “8.6.6” but the (old) IDLE 3.6.2’s Tk version still showed 8.5.9. I, then, installed ActiveTcl 8.5.18.0 after uninstalling ActiveTcl 8.6.6.8606 as a precaution. It  occurred to me that I may need to reinstall the Python 3.6.2 package from python.org only after installing the ActiveTcl 8.5.18.0.
msg302250 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-15 12:57
Glad it is working and thanks for the detail notes.

Ned, is there anything we should change on the web page?  Perhaps emphasize more not to upgrade to tcl/tk 8.6?  Is it usual to have to re-install python?

Alper, please do not revert headers after a core dev has changed them.  This was never about IDLE, except insofar as IDLE is a victim of the problem.  IDLE is a tkinter program and you could have written a tkinter program yourself with a similar problem.
msg302342 - (view) Author: ALPER PAKSOY (karakoyun) Date: 2017-09-16 14:44
I believe it would be better if IDLE was somehow mentioned in the header. This is partly the reason I failed to recognize that this was a problem encountered before.

new title suggestion: Apple tcl/tk crashes and causes IDLE to quit when caret character typed in IDLE
msg302344 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-16 16:41
OK.  This is more complete, still succinct enough, and still true.
msg302345 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-16 16:55
The 'all text' is apparently limited to 2 words.  'idle crash caret' in the title box gets this issue and the superseder above.  Move to all-text box and nothing is returned.  Delete 1 of 3 words and get multiple answers.
History
Date User Action Args
2017-09-16 16:55:45terry.reedysetmessages: + msg302345
2017-09-16 16:41:13terry.reedysetmessages: + msg302344
components: + macOS
title: Apple tcl/tk crashes and quits when caret character typed -> Mac Apple tcl/tk crashes program when caret ^ character typed in IDLE or tkinter
2017-09-16 14:44:15karakoyunsetmessages: + msg302342
2017-09-15 21:59:47terry.reedysetcomponents: - IDLE
title: IDLE 3 crashes and quits when caret character typed -> Apple tcl/tk crashes and quits when caret character typed
2017-09-15 12:57:29terry.reedysetassignee: terry.reedy ->
superseder: IDLE crashes when I press ^ caret key
messages: + msg302250
resolution: fixed -> duplicate
2017-09-14 18:22:47karakoyunsetstatus: open -> closed
messages: + msg302194

assignee: terry.reedy
components: + IDLE, - macOS, Tkinter
resolution: fixed
stage: resolved
2017-09-14 02:27:40terry.reedysetmessages: + msg302136
2017-09-14 01:48:10terry.reedysetmessages: + msg302135
2017-09-13 15:13:22karakoyunsetmessages: + msg302080
2017-09-13 04:52:08terry.reedysetnosy: + ned.deily, ronaldoussoren
messages: + msg302031

assignee: terry.reedy -> (no value)
components: + macOS, Tkinter, - IDLE
2017-09-13 01:26:21r.david.murraysetnosy: + r.david.murray
messages: + msg302026
2017-09-13 00:08:57karakoyuncreate