classification
Title: patchcheck alters content of .png files
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, pitrou, python-dev, rbcollins
Priority: normal Keywords:

Created on 2014-10-17 21:44 by rbcollins, last changed 2014-10-19 09:56 by georg.brandl. This issue is now closed.

Messages (5)
msg229609 - (view) Author: Robert Collins (rbcollins) * (Python committer) Date: 2014-10-17 21:44
cpython.hg$ make patchcheck
./python ./Tools/scripts/patchcheck.py
Getting the list of files that have been added/changed ... 448 files
Fixing whitespace ... 0 files
Fixing C file whitespace ... 5 files:
  Include/patchlevel.h
  Modules/_ctypes/callbacks.c
  Modules/_io/_iomodule.c
  Modules/_io/fileio.c
  Modules/_posixsubprocess.c
Fixing docs whitespace ... 1 file:
  Doc/tools/static/py.png
Docs modified ... yes
Misc/ACKS updated ... yes
Misc/NEWS updated ... yes
configure regenerated ... yes
pyconfig.h.in regenerated ... no

Note the change to py.png: its not a text filetohave its whitespace changed :/.
msg229613 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2014-10-17 22:32
I can't reproduce. Which platform are you on?
msg229679 - (view) Author: Roundup Robot (python-dev) Date: 2014-10-19 09:55
New changeset 3fa5d6a4bf78 by Georg Brandl in branch '3.4':
Closes #22663: patchcheck: only modify text files under Doc/
https://hg.python.org/cpython/rev/3fa5d6a4bf78
msg229680 - (view) Author: Roundup Robot (python-dev) Date: 2014-10-19 09:56
New changeset 4d53b34dd493 by Georg Brandl in branch '2.7':
Closes #22663: patchcheck: only modify text files under Doc/
https://hg.python.org/cpython/rev/4d53b34dd493
msg229681 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2014-10-19 09:56
What's actually curious is "Getting the list of files that have been added/changed ... 448 files".  What does "hg status" say?  Why are there 448 changed files?

This is of course still a bug in patchcheck.py, it shouldn't touch non-RST files.
History
Date User Action Args
2014-10-19 09:56:10georg.brandlsetmessages: + msg229681
2014-10-19 09:56:01python-devsetmessages: + msg229680
2014-10-19 09:55:51python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg229679

resolution: fixed
stage: resolved
2014-10-17 22:32:26pitrousetnosy: + georg.brandl, pitrou
messages: + msg229613
2014-10-17 21:44:47rbcollinscreate