classification
Title: pydistutils.cfg won't be found on Windows
Type: Stage:
Components: Distutils Versions: Python 3.0, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Make .pypirc handle multiple servers
View: 1858
Assigned To: Nosy List: christian.heimes, jafo, tarek
Priority: normal Keywords:

Created on 2008-02-23 14:17 by tarek, last changed 2008-03-20 00:31 by jafo. This issue is now closed.

Messages (4)
msg62731 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2008-02-23 14:17
Related to #1741: dist.py looks for the HOME environment variable
to try to find the user's pydistutils.cfg. 

user_file = os.path.join(os.environ.get('HOME'), user_filename)

It should look form HOMEDRIVE+HOMEPATH as well.
msg62743 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-02-23 15:15
Please use os.path.expanduser(os.path.join("~", user_filename))
msg62760 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2008-02-23 16:04
ok, done in #1858
msg64134 - (view) Author: Sean Reifschneider (jafo) * (Python committer) Date: 2008-03-20 00:31
Closing as a duplicate of 1858.
History
Date User Action Args
2008-03-20 00:31:56jafosetstatus: open -> closed
resolution: duplicate
messages: + msg64134
nosy: + jafo
2008-03-20 00:28:49jafosetpriority: normal
superseder: Make .pypirc handle multiple servers
2008-02-23 16:04:18tareksetmessages: + msg62760
2008-02-23 15:15:50christian.heimessetnosy: + christian.heimes
messages: + msg62743
2008-02-23 14:22:10tareksetcomponents: + Distutils
versions: + Python 3.0
2008-02-23 14:17:04tarekcreate