classification
Title: .pypirc not found on windows
Type: behavior Stage:
Components: Distutils Versions: Python 2.6, Python 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Make .pypirc handle multiple servers
View: 1858
Assigned To: Nosy List: gerdus, gvanrossum, jafo, tarek
Priority: normal Keywords: easy

Created on 2008-01-06 10:42 by gerdus, last changed 2008-03-20 00:30 by jafo. This issue is now closed.

Messages (5)
msg59353 - (view) Author: Gerdus van Zyl (gerdus) Date: 2008-01-06 10:45
register.py and upload.py both can't find the .pypirc on my system since
there is no HOME environment variable.
currently:
if os.environ.has_key('HOME'):
    rc = os.path.join(os.environ['HOME'], '.pypirc')
        if os.path.exists(rc):

works for me if changed to:
rc = os.path.expanduser('~/.pypirc')         
if os.path.exists(rc):
msg59354 - (view) Author: Gerdus van Zyl (gerdus) Date: 2008-01-06 10:46
Just to clarify I am using Windows XP
msg59429 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2008-01-07 04:14
Bug day candidate? 2.5.2 backport candidate.
msg62730 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2008-02-23 14:09
Fixed by #1858 patch
msg64132 - (view) Author: Sean Reifschneider (jafo) * (Python committer) Date: 2008-03-20 00:16
I'm closing this as a duplicate of #1858.
History
Date User Action Args
2008-03-20 00:30:36jafosetsuperseder: Make .pypirc handle multiple servers
2008-03-20 00:16:56jafosetstatus: open -> closed
nosy: + jafo
resolution: duplicate
messages: + msg64132
2008-02-23 14:09:24tareksetnosy: + tarek
messages: + msg62730
2008-01-12 01:06:21akuchlingsetkeywords: + easy
2008-01-07 04:14:06gvanrossumsetnosy: + gvanrossum
messages: + msg59429
2008-01-06 13:41:07christian.heimessetpriority: normal
type: behavior
versions: + Python 2.6
2008-01-06 10:46:21gerdussetmessages: + msg59354
2008-01-06 10:45:19gerdussetmessages: + msg59353
2008-01-06 10:42:25gerduscreate