classification
Title: test_signature_on_class() of test_inspect fails on "AMD64 FreeBSD 9.0 3.x" buildbot
Type: Stage:
Components: Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: larry Nosy List: larry, python-dev, skrah, vstinner, yselivanov
Priority: normal Keywords:

Created on 2014-02-01 03:14 by vstinner, last changed 2014-02-01 18:50 by yselivanov. This issue is now closed.

Messages (7)
msg209869 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-01 03:14
http://buildbot.python.org/all/builders/AMD64%20FreeBSD%209.0%203.x/builds/6302/steps/test/logs/stdio

======================================================================
ERROR: test_signature_on_class (test.test_inspect.TestSignatureObject)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/buildarea/3.x.krah-freebsd/build/Lib/test/test_inspect.py", line 2198, in test_signature_on_class
    self.assertEqual(str(inspect.signature(C)), '()')
  File "/usr/home/buildbot/buildarea/3.x.krah-freebsd/build/Lib/inspect.py", line 1734, in signature
    return signature(object)
  File "/usr/home/buildbot/buildarea/3.x.krah-freebsd/build/Lib/inspect.py", line 1695, in signature
    return Signature.from_builtin(obj)
  File "/usr/home/buildbot/buildarea/3.x.krah-freebsd/build/Lib/inspect.py", line 2196, in from_builtin
    raise ValueError("no signature found for builtin {!r}".format(func))
ValueError: no signature found for builtin <class 'object'>
msg209872 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-01 03:47
I'd like to investigate this, but I can't reproduce it.  So far it only happens on the "AMD64 FreeBSD 9.0 3.x" buildbot.

Is there a way I can get remote access to that machine?
msg209885 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2014-02-01 10:44
The build is --without-doc-strings. That should do the trick.
msg209888 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-01 11:23
Good thinking!  I don't know when I can get to it though, maybe Sunday.
msg209889 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2014-02-01 11:36
I think you just need to use the @requires_docstrings decorator for
the test. -- To me the failure looks expected if there aren't any
docstrings.
msg209908 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2014-02-01 18:49
New changeset b1f214165471 by Yury Selivanov in branch 'default':
inspect.tests: Fix tests to work on python built with '--without-doc-strings' #20471
http://hg.python.org/cpython/rev/b1f214165471
msg209909 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2014-02-01 18:50
Should be OK now. Thank you guys for the report and for the hint of what was going on ;)
History
Date User Action Args
2014-02-01 18:50:55yselivanovsetstatus: open -> closed
resolution: fixed
2014-02-01 18:50:46yselivanovsetmessages: + msg209909
2014-02-01 18:49:47python-devsetnosy: + python-dev
messages: + msg209908
2014-02-01 11:36:25skrahsetmessages: + msg209889
2014-02-01 11:23:49larrysetmessages: + msg209888
2014-02-01 10:44:48skrahsetnosy: + skrah
messages: + msg209885
2014-02-01 08:41:32yselivanovsetnosy: + yselivanov
2014-02-01 03:47:44larrysetassignee: larry
messages: + msg209872
2014-02-01 03:14:10vstinnercreate