classification
Title: test_asyncio hangs on Windows
Type: Stage:
Components: Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: gvanrossum, python-dev, sbt, vstinner
Priority: normal Keywords:

Created on 2014-01-31 13:15 by vstinner, last changed 2014-02-02 22:21 by vstinner. This issue is now closed.

Messages (4)
msg209783 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-01-31 13:15
It's probably a regression caused by my changeset 73dbb884eb09 which fixed a bug (issue #20449).

Related Tulip issue:
http://code.google.com/p/tulip/issues/detail?id=121
msg209785 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2014-01-31 13:18
New changeset 4c496d53b1e1 by Victor Stinner in branch 'default':
Issue #20455: asyncio: write a new write pipe transport class for proactor (on
http://hg.python.org/cpython/rev/4c496d53b1e1
msg209786 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-01-31 13:19
I commited my patch before a review (even if Guido already wrote me that the approach is correct) because I wanted to unblock Windows buildbots (which were all red).

Please review http://hg.python.org/cpython/rev/4c496d53b1e1
msg209797 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-01-31 15:30
(I removed the message msg209795 because the commits are related to #20452, not to this issue.)
History
Date User Action Args
2014-02-02 22:21:33vstinnersetstatus: open -> closed
resolution: fixed
2014-01-31 15:30:51vstinnersetmessages: + msg209797
2014-01-31 15:30:06vstinnersetmessages: - msg209795
2014-01-31 15:28:05python-devsetmessages: + msg209795
2014-01-31 13:19:55vstinnersetmessages: + msg209786
2014-01-31 13:18:54python-devsetnosy: + python-dev
messages: + msg209785
2014-01-31 13:15:00vstinnercreate