classification
Title: setup.py upload option repeated in docs
Type: behavior Stage: resolved
Components: Distutils, Documentation Versions: Python 3.2, Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: chris.jerdonek Nosy List: berker.peksag, chris.jerdonek, eric.araujo, mrshu, python-dev, tarek
Priority: normal Keywords: easy, patch

Created on 2013-01-06 01:14 by chris.jerdonek, last changed 2013-01-11 16:21 by eric.araujo. This issue is now closed.

Files
File name Uploaded Description Edit
distutils-upload-markup.diff berker.peksag, 2013-01-10 13:19 review
issue-16874-1-27.patch chris.jerdonek, 2013-01-11 06:21
Messages (7)
msg179162 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2013-01-06 01:14
The following page:

http://docs.python.org/dev/distutils/uploading.html

says, "Other upload options include --repository= or --repository= where url..."

I haven't looked into what the correct wording is meant to be.
msg179539 - (view) Author: Marek Šuppa (mrshu) * Date: 2013-01-10 12:54
So what do you think should be done here?

Just removing the "or --repository=" part?
msg179540 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2013-01-10 13:19
I think the problem is the usage of `:option:`.

|:option:`--repository=<url>` or :option:`--repository=<section>`| should be written like |:option:`--repository=*url*` or :option:`--repository=*section*`|

See:

- http://hg.python.org/cpython/file/default/Doc/distutils/uploading.rst#l39
- http://hg.python.org/cpython/file/default/Doc/distutils/uploading.rst#l28

Patch attached.
msg179631 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2013-01-11 05:08
I will take care of this (formatting issue).
msg179636 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2013-01-11 06:21
The attached patch applies to all branches.
msg179639 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2013-01-11 07:05
New changeset a30c36fbefcf by Chris Jerdonek in branch '2.7':
Issue #16874: fix formatting of setup.py upload options in documentation.
http://hg.python.org/cpython/rev/a30c36fbefcf

New changeset dcb645b9de4c by Chris Jerdonek in branch '3.2':
Issue #16874 (forward-port from 2.7): fix some documentation formatting.
http://hg.python.org/cpython/rev/dcb645b9de4c

New changeset 63fff55a167f by Chris Jerdonek in branch '3.3':
Issue #16874 (merge from 3.2): fix some documentation formatting.
http://hg.python.org/cpython/rev/63fff55a167f

New changeset 860a2f6282c4 by Chris Jerdonek in branch 'default':
Issue #16874 (merge from 3.3): fix some documentation formatting.
http://hg.python.org/cpython/rev/860a2f6282c4
msg179696 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2013-01-11 16:21
Thanks.
History
Date User Action Args
2013-01-11 16:21:34eric.araujosetmessages: + msg179696
2013-01-11 07:07:55chris.jerdoneksetstatus: open -> closed
resolution: fixed
stage: needs patch -> resolved
2013-01-11 07:05:23python-devsetnosy: + python-dev
messages: + msg179639
2013-01-11 06:21:51chris.jerdoneksetfiles: + issue-16874-1-27.patch

messages: + msg179636
2013-01-11 05:08:24chris.jerdoneksetassignee: eric.araujo -> chris.jerdonek
messages: + msg179631
2013-01-10 13:19:37berker.peksagsetfiles: + distutils-upload-markup.diff

nosy: + berker.peksag
messages: + msg179540

keywords: + patch
2013-01-10 12:54:42mrshusetnosy: + mrshu
messages: + msg179539
2013-01-06 01:14:24chris.jerdonekcreate