classification
Title: Can't get a list of modules in Python's help system
Type: crash Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: python.exe crashes or hangs on help() modules when bad modules found
View: 10060
Assigned To: docs@python Nosy List: docs@python, r.david.murray, vertograd.phrokhladny
Priority: normal Keywords:

Created on 2012-12-27 18:56 by vertograd.phrokhladny, last changed 2012-12-28 20:12 by vertograd.phrokhladny. This issue is now closed.

Files
File name Uploaded Description Edit
modules_command_crash.log vertograd.phrokhladny, 2012-12-27 18:56 this's output of "modules" help command
Messages (3)
msg178310 - (view) Author: vertograd phrokhladny (vertograd.phrokhladny) Date: 2012-12-27 18:56
Ubuntu 12.4 LTS
msg178311 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-12-27 19:07
This is a duplicate of issue 10060, and as indicated there there really isn't much Python can do about this.  You should report the bug to Ubuntu, but I'm pretty sure there is already a bug in their system for it (which I believe has been fixed).
msg178423 - (view) Author: vertograd phrokhladny (vertograd.phrokhladny) Date: 2012-12-28 20:12
Re:
    2012/12/27 R. David Murray <report@bugs.python.org>

>
> R. David Murray added the comment:
>
> This is a duplicate of issue 10060, and as indicated there there really
> isn't much Python can do about this.  You should report the bug to Ubuntu,
> but I'm pretty sure there is already a bug in their system for it (which I
> believe has been fixed).
>
>
           Thanks for your comment. I've looked through that very
continuous thread (issue 10060) and than went to Ubuntu.You're  right  ,
there's   bug  #896836 (and several duplicates)   reported  on 2011-11-27
(for Oneiric) with confirmed status. As I understood from recommended
reading  the segmentation fault occurs
because of the conflict between loading dynamic and static bindings in C
based modules.Unfortunately there's no fix for it yet.
History
Date User Action Args
2012-12-28 20:12:05vertograd.phrokhladnysetmessages: + msg178423
2012-12-27 19:07:07r.david.murraysetstatus: open -> closed

superseder: python.exe crashes or hangs on help() modules when bad modules found

nosy: + r.david.murray
messages: + msg178311
resolution: duplicate
stage: resolved
2012-12-27 18:56:46vertograd.phrokhladnycreate