classification
Title: Windows C Runtime Library Mismatch
Type: crash Stage:
Components: Installation, Windows Versions: Python 2.7
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, brian.curtin, jkloth, loewis, rlinscheer, tim.golden
Priority: normal Keywords:

Created on 2012-10-10 15:06 by rlinscheer, last changed 2014-07-03 21:30 by rlinscheer. This issue is now closed.

Files
File name Uploaded Description Edit
rob_32.txt rlinscheer, 2012-10-10 15:06 Output from sxstrace on 32-bit python 2.7.3
Messages (3)
msg172584 - (view) Author: rlinscheer (rlinscheer) Date: 2012-10-10 15:06
When installing python-2.7.3.amd64.msi or python-2.7.3.msi and selecting for single-user (as opposed to for all users), an incorrect version of the microsoft C runtime library (msvcr90.dll) seems to be placed into the top-level directory along side the python executable.  This results in the message:

The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.

The event log shows the error too:

Activation context generation failed for "C:\python_rob_32\pythonw.exe".Error in manifest or policy file "C:\python_rob_32\Microsoft.VC90.CRT.MANIFEST" on line 4. Component identity found in manifest does not match the identity of the component requested. Reference is Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8". Definition is Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.30729.1". Please use sxstrace.exe for detailed diagnosis.

Running the sxstrace tool shows the following:

INFO: Parsing Manifest File C:\python_rob_32\Microsoft.VC90.CRT.MANIFEST.
	INFO: Manifest Definition Identity is Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.30729.1".
	ERROR: Component identity found in manifest does not match the identity of the component requested. Reference is Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8". Definition is Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.30729.1".
ERROR: Activation Context generation failed.

This would seem to be the relevant section of the trace, though I have attached the full output of the sxstrace if desired.

This leads me to the conclusion that a newer version of the C runtime library is being shipped with the python executable that was built with an older version.

This problem was mentioned with less detail in issue 14608, but closed without resolution as far as I can tell.
msg222214 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-07-03 21:03
I'm not aware of any similar problems being reported with any Python version so can this be closed "not a bug" as was #14608 ?
msg222219 - (view) Author: rlinscheer (rlinscheer) Date: 2014-07-03 21:30
Quite frankly, I'm beyond caring now.
History
Date User Action Args
2014-07-03 21:30:26rlinscheersetstatus: open -> closed
resolution: wont fix
messages: + msg222219
2014-07-03 21:03:22BreamoreBoysetnosy: + BreamoreBoy
messages: + msg222214
2012-10-10 22:43:33jklothsetnosy: + jkloth
2012-10-10 18:46:43ned.deilysetnosy: + loewis, tim.golden, brian.curtin
components: + Windows
2012-10-10 15:06:31rlinscheercreate