classification
Title: Python 2.7.3 x86 msi - msvcr90.dll version mismatch
Type: behavior Stage:
Components: Installation, Windows Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: alexandrul, loewis
Priority: normal Keywords:

Created on 2012-04-17 21:31 by alexandrul, last changed 2012-04-18 08:15 by alexandrul. This issue is now closed.

Messages (7)
msg158569 - (view) Author: Eduard (alexandrul) Date: 2012-04-17 21:31
After installing Python 2.7.3, inside the Python folder I have version 9.0.30729.1 of msvcr90.dll, but it seems that the embeded redistributable package contains the 9.0.21022.8 version of msvcm90.dll, msvcp90.dll, and msvcr90.dll

Is this the intended behavior?
msg158574 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-04-17 23:06
It's not explicitly intended, but a side effect of how Microsoft distributes patches. The redistributable package comes from %ProgramFiles%\Common Files\Merge Modules, whereas the separate copy comes from %VS90COMNTOOLS%\..\..\VC\redist. Apparently, the Windows Update process updated one and not the other.

Apparently, an update to the merge modules is included in

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=11895

I'll see whether this actually does update the merge modules. In general, while not being intended, this version difference is expected.
msg158585 - (view) Author: Eduard (alexandrul) Date: 2012-04-18 03:34
I was reading about py2exe and found this old thread: https://groups.google.com/d/msg/wxpython-users/fwHt9zSbnsE/IV3aryIBrd8J

I'm not familiar with C++ and redists and stuff, but I find it strange that the manifest from the Python folder requires a specific version, and the installed runtime is another version. Would it be ok if I'll just install the 9.0.30729.1 runtime by hand? Or any 9.0.30729.xxxx version is good enough?
msg158586 - (view) Author: Eduard (alexandrul) Date: 2012-04-18 03:41
There is a newer redist available: 9.0.30729.6161 from http://www.microsoft.com/download/en/details.aspx?id=26368
msg158595 - (view) Author: Eduard (alexandrul) Date: 2012-04-18 06:56
OTOH, the manifest embedded in python.exe references version 9.0.21022.8

I'm going to delete Microsoft.VC90.CRT.manifest and msvcr90.dll from Python installation folder and postpone py2exe experiments a bit.
msg158596 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-04-18 07:15
Eduard: is all this causing *actual* problems? Any version should be fine.
msg158598 - (view) Author: Eduard (alexandrul) Date: 2012-04-18 08:15
> Any version should be fine.

This is all I need to know. It's just one less place to check in case of troubles.

Thank you for your time and patience.
History
Date User Action Args
2012-04-18 08:15:04alexandrulsetstatus: open -> closed
resolution: not a bug
messages: + msg158598
2012-04-18 07:15:49loewissetmessages: + msg158596
2012-04-18 06:56:50alexandrulsetmessages: + msg158595
2012-04-18 03:41:35alexandrulsetmessages: + msg158586
2012-04-18 03:34:35alexandrulsetmessages: + msg158585
2012-04-17 23:06:24loewissetmessages: + msg158574
2012-04-17 21:36:48floxsetnosy: + loewis
components: + Windows
2012-04-17 21:31:26alexandrulcreate