classification
Title: Irrelevant references to Misc/News
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.3, Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ezio.melotti Nosy List: chris.jerdonek, docs@python, ezio.melotti, georg.brandl, python-dev, r.david.murray, serhiy.storchaka
Priority: normal Keywords:

Created on 2012-10-07 16:54 by serhiy.storchaka, last changed 2012-11-17 17:32 by ezio.melotti. This issue is now closed.

Messages (6)
msg172321 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-10-07 16:54
Older versions (3.2 for 3.3, 3.2 and 3.3 for 3.4) whatsnew refers to Misc/News which contains changes only for currect version ("For full details, see the :source:`Misc/NEWS <Misc/NEWS>` file.").

http://docs.python.org/3.3/whatsnew/3.2.html
http://docs.python.org/3.4/whatsnew/3.2.html
http://docs.python.org/3.4/whatsnew/3.3.html
msg172322 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-10-07 17:00
The problem is that the source directive (from pyspecific in Sphinx) uses the 'current branch' for which the docs are being built.  Probably we will have to hardcode the links rather than using the source directive.
msg175544 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-11-14 07:19
Even better would be to link to the changelog page instead, but that's only available for Python 3.3/3.4 (does this issue affect 2.7/3.2?).

http://docs.python.org/3.3/whatsnew/changelog.html
msg175549 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-11-14 08:24
This issue affects only 3.3+ (see links above).
msg175785 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-11-17 17:30
New changeset d6cd283bb4c2 by Ezio Melotti in branch '3.3':
#16157: fix links in the whatsnew files.
http://hg.python.org/cpython/rev/d6cd283bb4c2

New changeset 9a08c9443c54 by Ezio Melotti in branch 'default':
#16157: merge with 3.3.
http://hg.python.org/cpython/rev/9a08c9443c54
msg175786 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-11-17 17:32
This should be fixed now.
I linked to http://hg.python.org/cpython/file/3.2/Misc/NEWS for the 3.2 whatsnew and to http://docs.python.org/3.3/whatsnew/changelog.html and http://docs.python.org/3.4/whatsnew/changelog.html for 3.3 and 3.4 respectively.
History
Date User Action Args
2012-11-17 17:32:05ezio.melottisetstatus: open -> closed
messages: + msg175786

assignee: docs@python -> ezio.melotti
resolution: fixed
stage: needs patch -> resolved
2012-11-17 17:30:59python-devsetnosy: + python-dev
messages: + msg175785
2012-11-14 08:24:21serhiy.storchakasetmessages: + msg175549
2012-11-14 07:19:19ezio.melottisetnosy: + ezio.melotti, georg.brandl

messages: + msg175544
stage: needs patch
2012-11-13 18:39:10chris.jerdoneksetnosy: + chris.jerdonek
2012-10-07 17:00:40r.david.murraysetnosy: + r.david.murray
messages: + msg172322
2012-10-07 16:54:12serhiy.storchakacreate