classification
Title: about the slowly HTTPServer
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Logging in BaseHTTPServer.BaseHTTPRequestHandler causes lag
View: 6085
Assigned To: Nosy List: Fan.Li, neologix
Priority: normal Keywords:

Created on 2012-05-30 06:43 by Fan.Li, last changed 2012-05-30 07:03 by neologix. This issue is now closed.

Messages (2)
msg161931 - (view) Author: Fan Li (Fan.Li) Date: 2012-05-30 06:43
first, i'm sorry about my english.

when i test the HTTPServer lib local, it's fast. but when i run the test script on another PC, i found it very slow, response for a request cost about 4s.

then, i walk into the source about HTTPServer and found an function which just print some infomation about the request like this: 
xxx.xxx.xxx.xxx - 'GET /path/xxx.xxx' 200

i cost 4s long!! just because it call a function name getfqdn(), it's very slow to do this.

then i overwrite the BaseHttpRequest.log_message, problem solved.

may be you can remove the function getfqdn() ?
msg161932 - (view) Author: Charles-Fran├žois Natali (neologix) * (Python committer) Date: 2012-05-30 07:03
It's actually a duplicate of #6085 (already fixed).

Cheers!
History
Date User Action Args
2012-05-30 07:03:14neologixsetstatus: open -> closed

superseder: Logging in BaseHTTPServer.BaseHTTPRequestHandler causes lag

nosy: + neologix
messages: + msg161932
resolution: duplicate
stage: resolved
2012-05-30 06:43:22Fan.Licreate