classification
Title: Regression for http.client read()
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Jon.Kuhn, orsenthil, pitrou, python-dev, rosslagerwall
Priority: critical Keywords: patch

Created on 2012-01-04 16:38 by rosslagerwall, last changed 2012-01-04 18:00 by pitrou. This issue is now closed.

Files
File name Uploaded Description Edit
test.py rosslagerwall, 2012-01-04 16:38 test program
readinto_chunked.patch pitrou, 2012-01-04 17:48 review
Messages (5)
msg150615 - (view) Author: Ross Lagerwall (rosslagerwall) (Python committer) Date: 2012-01-04 16:38
806cfe39f729 introduced a regression for http.client read(len).

To see this:
$ ./python test.py
$ wget http://archives.fedoraproject.org/pub/archive/fedora/linux/core/1/SRPMS/
$ diff index.html index2.html

This is a difference in the files (which there shouldn't be).

The change which introduced the problem was:
changeset:   73875:806cfe39f729
user:        Antoine Pitrou <solipsis@pitrou.net>
date:        Tue Dec 06 22:33:57 2011 +0100
summary:     Issue #13464: Add a readinto() method to http.client.HTTPResponse.
msg150623 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-01-04 17:48
The fix is quite trivial. Here is a patch + tests.
msg150624 - (view) Author: Ross Lagerwall (rosslagerwall) (Python committer) Date: 2012-01-04 17:56
The patch looks right and seems to fix the issue. Thanks :-)
msg150626 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-01-04 17:58
New changeset 4b21f651eeee by Antoine Pitrou in branch 'default':
Issue #13713: fix a regression in HTTP chunked reading after 806cfe39f729
http://hg.python.org/cpython/rev/4b21f651eeee
msg150628 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-01-04 18:00
Ok, committed!
(Jon, don't worry, such things happen :-))
History
Date User Action Args
2012-01-04 18:00:54pitrousetstatus: open -> closed
resolution: fixed
messages: + msg150628

stage: patch review -> resolved
2012-01-04 17:58:37python-devsetnosy: + python-dev
messages: + msg150626
2012-01-04 17:56:23rosslagerwallsetmessages: + msg150624
2012-01-04 17:48:27pitrousetfiles: + readinto_chunked.patch
keywords: + patch
messages: + msg150623

stage: needs patch -> patch review
2012-01-04 17:14:54pitrousetpriority: normal -> critical
nosy: + Jon.Kuhn
2012-01-04 16:38:39rosslagerwallcreate