classification
Title: setup.cfg isn't packaged when running sdist
Type: behavior Stage: resolved
Components: Distutils2 Versions: Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: tarek Nosy List: Julien.Miotte, eric.araujo, gotcha, python-dev, tarek, vstinner
Priority: normal Keywords:

Created on 2011-02-01 17:42 by Julien.Miotte, last changed 2011-06-07 15:56 by eric.araujo. This issue is now closed.

Messages (5)
msg127705 - (view) Author: Julien Miotte (Julien.Miotte) Date: 2011-02-01 17:42
Operating System: Ubuntu Maverick
Version of Python: 2.6.6
Version of Distutils2: d355f123ac79

How to reproduce: Create a project bato with a setup.cfg, like this: 
[metadata]
name = bato
version = 1.0

Run:
$ python -m distutils2.run sdist
$ tar tf dist/bato-1.0.tar.gz

What happens: The archive doesn't contain the setup.cfg file.
msg127709 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-02-01 22:02
You can add it to MANIFEST.in.
msg127759 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-02-02 20:34
No, because setup.cfg should always be included.  That’s a real bug.  In distutils1, test/*.py and README[.txt] were also included; the commit that changed that (374f93ab103c) introduced this bug:

-        optional = ['test/test*.py', 'setup.cfg']
-        for pattern in optional:
-            files = filter(os.path.isfile, glob(pattern))
-            if files:
-                self.filelist.extend(files)

I think setup.cfg should always be included if it exists; I’m not sure about setup.py, you may want to ask on the ML.
msg137836 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2011-06-07 15:32
New changeset 5940d2d82dee by Éric Araujo in branch 'default':
Fix sdist to always include setup.cfg (#11092), to comply with the spec
http://hg.python.org/cpython/rev/5940d2d82dee
msg137844 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-06-07 15:56
This is now fixed.
History
Date User Action Args
2011-06-07 15:56:43eric.araujosetstatus: open -> closed

title: Setup.cfg isn't packaged when running sdist -> setup.cfg isn't packaged when running sdist
messages: + msg137844
versions: + Python 3.3, - 3rd party
type: behavior
resolution: fixed
stage: resolved
2011-06-07 15:32:01python-devsetnosy: + python-dev
messages: + msg137836
2011-02-02 20:34:05eric.araujosetnosy: + gotcha
messages: + msg127759
2011-02-01 22:02:58vstinnersetnosy: + vstinner
messages: + msg127709
2011-02-01 17:42:31Julien.Miottecreate