classification
Title: Build of 2.7 svn fails in readline
Type: compile error Stage:
Components: Build Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: brett.cannon, grgoffe@yahoo.com, loewis
Priority: normal Keywords:

Created on 2011-01-26 02:10 by grgoffe@yahoo.com, last changed 2011-01-27 21:58 by brett.cannon. This issue is now closed.

Files
File name Uploaded Description Edit
readline.i.gz grgoffe@yahoo.com, 2011-01-27 18:49
unnamed grgoffe@yahoo.com, 2011-01-27 19:58
unnamed grgoffe@yahoo.com, 2011-01-27 20:21
unnamed grgoffe@yahoo.com, 2011-01-27 21:40
unnamed grgoffe@yahoo.com, 2011-01-27 21:51
Messages (13)
msg127080 - (view) Author: Geoge R. Goffe (grgoffe@yahoo.com) Date: 2011-01-26 02:10
Howdy,

I just updated my copy of the SVN version of 2.7 and got the following error messages. Did I do something wrong?

Regards,

George...

building dbm using bdb
building 'readline' extension
gcc -pthread -fPIC -fno-strict-aliasing -g -O2 -g -O0 -Wall -Wstrict-prototypes -I/usr/lsd/Linux/include -I. -IInclude -I./Include -I/usr/local/include -I/usr/local/google/tools/python/release27-maint/Include -I/usr/local/google/tools/python/release27-maint -c /usr/local/google/tools/python/release27-maint/Modules/readline.c -o build/temp.linux-x86_64-2.7-pydebug/usr/local/google/tools/python/release27-maint/Modules/readline.o
/usr/local/google/tools/python/release27-maint/Modules/readline.c: In function ‘write_history_file’:
/usr/local/google/tools/python/release27-maint/Modules/readline.c:147: warning: implicit declaration of function ‘history_truncate_file’
/usr/local/google/tools/python/release27-maint/Modules/readline.c: In function ‘_py_free_history_entry’:
/usr/local/google/tools/python/release27-maint/Modules/readline.c:385: warning: passing argument 1 of ‘free’ discards qualifiers from pointer target type
/usr/include/stdlib.h:488: note: expected ‘void *’ but argument is of type ‘const char *’
/usr/local/google/tools/python/release27-maint/Modules/readline.c: In function ‘py_replace_history’:
/usr/local/google/tools/python/release27-maint/Modules/readline.c:436: warning: implicit declaration of function ‘replace_history_entry’
/usr/local/google/tools/python/release27-maint/Modules/readline.c:436: warning: assignment makes pointer from integer without a cast
/usr/local/google/tools/python/release27-maint/Modules/readline.c: In function ‘_py_get_history_length’:
/usr/local/google/tools/python/release27-maint/Modules/readline.c:523: error: ‘HISTORY_STATE’ undeclared (first use in this function)
/usr/local/google/tools/python/release27-maint/Modules/readline.c:523: error: (Each undeclared identifier is reported only once
/usr/local/google/tools/python/release27-maint/Modules/readline.c:523: error: for each function it appears in.)
/usr/local/google/tools/python/release27-maint/Modules/readline.c:523: error: ‘hist_st’ undeclared (first use in this function)
/usr/local/google/tools/python/release27-maint/Modules/readline.c:523: warning: implicit declaration of function ‘history_get_history_state’
/usr/local/google/tools/python/release27-maint/Modules/readline.c: In function ‘insert_text’:
/usr/local/google/tools/python/release27-maint/Modules/readline.c:628: warning: implicit declaration of function ‘rl_insert_text’
/usr/local/google/tools/python/release27-maint/Modules/readline.c: In function ‘flex_complete’:
/usr/local/google/tools/python/release27-maint/Modules/readline.c:847: error: ‘rl_completion_suppress_append’ undeclared (first use in this function)
/usr/local/google/tools/python/release27-maint/Modules/readline.c:853: warning: implicit declaration of function ‘rl_completion_matches’
/usr/local/google/tools/python/release27-maint/Modules/readline.c:853: error: ‘rl_compentry_func_t’ undeclared (first use in this function)
/usr/local/google/tools/python/release27-maint/Modules/readline.c:853: error: expected expression before ‘)’ token
/usr/local/google/tools/python/release27-maint/Modules/readline.c: In function ‘setup_readline’:
/usr/local/google/tools/python/release27-maint/Modules/readline.c:886: warning: passing argument 2 of ‘rl_bind_key_in_map’ from incompatible pointer type
/usr/lsd/Linux/include/readline/readline.h:195: note: expected ‘int (*)(const char *, int)’ but argument is of type ‘int (*)(int,  int)’
/usr/local/google/tools/python/release27-maint/Modules/readline.c:887: warning: passing argument 2 of ‘rl_bind_key_in_map’ from incompatible pointer type
/usr/lsd/Linux/include/readline/readline.h:195: note: expected ‘int (*)(const char *, int)’ but argument is of type ‘int (*)(int,  int)’
/usr/local/google/tools/python/release27-maint/Modules/readline.c: In function ‘readline_until_enter_or_signal’:
/usr/local/google/tools/python/release27-maint/Modules/readline.c:940: error: ‘rl_catch_signals’ undeclared (first use in this function)
/usr/local/google/tools/python/release27-maint/Modules/readline.c:979: warning: implicit declaration of function ‘rl_free_line_state’
/usr/local/google/tools/python/release27-maint/Modules/readline.c:980: warning: implicit declaration of function ‘rl_cleanup_after_signal’

Python build finished, but the necessary bits to build these modules were not found:
bsddb185           dl                 gdbm            
imageop            sunaudiodev                        
To find the necessary bits, look in setup.py in detect_modules() for the module's name.


Failed to build these modules:
readline
msg127082 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2011-01-26 02:14
Did you try a `make distclean` before compiling?
msg127090 - (view) Author: Geoge R. Goffe (grgoffe@yahoo.com) Date: 2011-01-26 04:33
Brett,

THANKS for your response, it's appreciated.

Yes I did... I always do that. I use a more or less standard script to build 
software. I can send the script tomorrow if you would like to see it.

Regards and THANKS for your response.

George...

 "It's not what you know that hurts you, It's what you know that ain't so." Wil 
Rogers

________________________________
From: Brett Cannon <report@bugs.python.org>
To: grgoffe@yahoo.com
Sent: Tue, January 25, 2011 6:14:56 PM
Subject: [issue11013] Build of  2.7 svn fails in readline

Brett Cannon <brett@python.org> added the comment:

Did you try a `make distclean` before compiling?

----------
nosy: +brett.cannon
title: Build of CVS version 2.7 fails in readline -> Build of  2.7 svn fails in 
readline

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue11013>
_______________________________________
msg127096 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-01-26 09:35
Please run

gcc -pthread -fPIC -fno-strict-aliasing -g -O2 -g -O0 -Wall -Wstrict-prototypes -I/usr/lsd/Linux/include -I. -IInclude -I./Include -I/usr/local/include -I/usr/local/google/tools/python/release27-maint/Include -I/usr/local/google/tools/python/release27-maint -c /usr/local/google/tools/python/release27-maint/Modules/readline.c -o build/temp.linux-x86_64-2.7-pydebug/usr/local/google/tools/python/release27-maint/Modules/readline.o --save-temps

and attach the resulting readline.i to this report (compressed if necessary).
msg127208 - (view) Author: Geoge R. Goffe (grgoffe@yahoo.com) Date: 2011-01-27 18:49
Brett,

Here's the file you requested.

Thanks for your help.

George...
msg127212 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2011-01-27 19:02
Martin actually asked for the file and deserves the thanks.
msg127216 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-01-27 19:38
What is /usr/lsd/Linux? This seems broken. Please take a look at /usr/lsd/Linux/include/readline/history.h - it appears to be an empty file. Make sure you have a working copy of the readline header files installed, and make sure the build process picks them up.
msg127217 - (view) Author: Geoge R. Goffe (grgoffe@yahoo.com) Date: 2011-01-27 19:58
Martin,

I'm looking at the file right now. history.h is a link to readline.h which has 6771 characters in it.

George...

goffe@goffeg bash-4.1 /usr/lsd };-) find . -name 'readline.h' -ls
205381    8 -r--r--r--   1 goffe    nonconf      6771 Nov 23 11:49 ./Linux/include/readline/readline.h
goffe@goffeg bash-4.1 /usr/lsd };-) l /usr/lsd/Linux/include/readline/history.h
lrwxrwxrwx 1 goffe nonconf 10 Nov 23 11:49 /usr/lsd/Linux/include/readline/history.h -> readline.h
goffe@goffeg bash-4.1 /usr/lsd };-) l /usr/lsd/Linux/include/readline/readline.h
-r--r--r-- 1 goffe nonconf 6771 Nov 23 11:49 /usr/lsd/Linux/include/readline/readline.h

"It's not what you know that hurts you, It's what you know that ain't so." Wil Rogers

--- On Thu, 1/27/11, Martin v. Löwis <report@bugs.python.org> wrote:

From: Martin v. Löwis <report@bugs.python.org>
Subject: [issue11013] Build of  2.7 svn fails in readline
To: grgoffe@yahoo.com
Date: Thursday, January 27, 2011, 11:38 AM

Martin v. Löwis <martin@v.loewis.de> added the comment:

What is /usr/lsd/Linux? This seems broken. Please take a look at /usr/lsd/Linux/include/readline/history.h - it appears to be an empty file. Make sure you have a working copy of the readline header files installed, and make sure the build process picks them up.

----------

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue11013>
_______________________________________
msg127219 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-01-27 20:12
> I'm looking at the file right now. history.h is a link to readline.h

Ah, that's wrong. It must be a separate file, entirely different from
readline.h.
msg127220 - (view) Author: Geoge R. Goffe (grgoffe@yahoo.com) Date: 2011-01-27 20:21
Martin,

I traced back to where that readline installation came from... It's the latest version from ftp.gnu.org + patches.

George...

"It's not what you know that hurts you, It's what you know that ain't so." Wil Rogers

--- On Thu, 1/27/11, Martin v. Löwis <report@bugs.python.org> wrote:

From: Martin v. Löwis <report@bugs.python.org>
Subject: [issue11013] Build of  2.7 svn fails in readline
To: grgoffe@yahoo.com
Date: Thursday, January 27, 2011, 12:12 PM

Martin v. Löwis <martin@v.loewis.de> added the comment:

> I'm looking at the file right now. history.h is a link to readline.h

Ah, that's wrong. It must be a separate file, entirely different from
readline.h.

----------

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue11013>
_______________________________________
msg127221 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-01-27 20:29
> I traced back to where that readline installation came from... It's
> the latest version from ftp.gnu.org + patches.

Did you mean to imply that you have now fixed your installation, or that
you consider it correct?
msg127226 - (view) Author: Geoge R. Goffe (grgoffe@yahoo.com) Date: 2011-01-27 21:40
Martin,

After the rebuild/reinstall of readline, readline.h is different than history.h... AND NOT A LINK. NO OTHER CHANGES. Same build script...

I did NOT do "svn up" but this current build attempt succeeded. AND THE BEST PART... command line editing works now.  This probably explains why my python-3.x build and IDLE didn't do command line editing either. Sigh... To err is human, to get things really screwed up requires a computer.

I wonder why I had this problem with readline? Maybe it only happens with a fresh install? I'll try that.

Let me do an svn up and re-build... This worked WITHOUT INCIDENT. Go figure...

I guess you can close this bug... If I discover what the problem is/was, I'll let you guys know.

THANKS for all your help...

George...

"It's not what you know that hurts you, It's what you know that ain't so." Wil Rogers

--- On Thu, 1/27/11, Martin v. Löwis <report@bugs.python.org> wrote:

From: Martin v. Löwis <report@bugs.python.org>
Subject: [issue11013] Build of  2.7 svn fails in readline
To: grgoffe@yahoo.com
Date: Thursday, January 27, 2011, 12:29 PM

Martin v. Löwis <martin@v.loewis.de> added the comment:

> I traced back to where that readline installation came from... It's
> the latest version from ftp.gnu.org + patches.

Did you mean to imply that you have now fixed your installation, or that
you consider it correct?

----------

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue11013>
_______________________________________
msg127228 - (view) Author: Geoge R. Goffe (grgoffe@yahoo.com) Date: 2011-01-27 21:51
Martin,

command line editing with 3.2 (I just did a "svn co") works now as well...

Regards and have a GREAT day,

George...

"It's not what you know that hurts you, It's what you know that ain't so." Wil Rogers

--- On Thu, 1/27/11, Martin v. Löwis <report@bugs.python.org> wrote:

From: Martin v. Löwis <report@bugs.python.org>
Subject: [issue11013] Build of  2.7 svn fails in readline
To: grgoffe@yahoo.com
Date: Thursday, January 27, 2011, 12:29 PM

Martin v. Löwis <martin@v.loewis.de> added the comment:

> I traced back to where that readline installation came from... It's
> the latest version from ftp.gnu.org + patches.

Did you mean to imply that you have now fixed your installation, or that
you consider it correct?

----------

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue11013>
_______________________________________
History
Date User Action Args
2011-01-27 21:58:09brett.cannonsetstatus: open -> closed
resolution: not a bug
2011-01-27 21:51:43grgoffe@yahoo.comsetfiles: + unnamed

messages: + msg127228
2011-01-27 21:40:47grgoffe@yahoo.comsetfiles: + unnamed

messages: + msg127226
2011-01-27 20:29:37loewissetmessages: + msg127221
2011-01-27 20:21:05grgoffe@yahoo.comsetfiles: + unnamed

messages: + msg127220
2011-01-27 20:12:03loewissetmessages: + msg127219
2011-01-27 19:58:48grgoffe@yahoo.comsetfiles: + unnamed

messages: + msg127217
2011-01-27 19:38:23loewissetmessages: + msg127216
2011-01-27 19:02:18brett.cannonsetmessages: + msg127212
2011-01-27 18:49:20grgoffe@yahoo.comsetfiles: + readline.i.gz
status: pending -> open

messages: + msg127208
2011-01-26 17:39:19brett.cannonsetstatus: open -> pending
2011-01-26 17:39:11brett.cannonsetfiles: - unnamed
2011-01-26 09:35:58loewissetnosy: + loewis
messages: + msg127096
2011-01-26 04:33:48grgoffe@yahoo.comsetfiles: + unnamed

messages: + msg127090
2011-01-26 02:14:56brett.cannonsetnosy: + brett.cannon

messages: + msg127082
title: Build of CVS version 2.7 fails in readline -> Build of 2.7 svn fails in readline
2011-01-26 02:10:31grgoffe@yahoo.comcreate