classification
Title: py3k os.popen result is not iterable, patch attached
Type: behavior Stage:
Components: Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: aimacintyre Nosy List: aimacintyre, christian.heimes, ezio.melotti, pitrou, python-dev
Priority: normal Keywords: patch

Created on 2007-09-02 17:37 by carsten.haese, last changed 2012-09-26 17:02 by python-dev. This issue is now closed.

Files
File name Uploaded Description Edit
py3k_os_popen_iter.patch carsten.haese, 2007-09-02 17:38
Messages (5)
msg57249 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-08 14:17
os.popen was reimplemented a while ago. It's using the subprocess. I've
added a unit test to verify the existence of __iter__() in r58912.
msg95365 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-11-17 05:11
While I was working on EnvironTests I found 'test_os_popen_iter' (added
in r58912) and I don't see why it is there.
Christian, did you put it in the wrong place by mistake or is it somehow
related to os.environ?
(the test should also use unittest.skipUnless(os.path.exists("/bin/sh"))
instead of the 'if')
msg96571 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-12-18 17:02
Does anybody know why _wrap_close wraps TextIOWrapper rather than
inherit it?
msg96572 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-12-18 17:04
Oops, I hadn't seen this bug is closed. Sorry.
msg171348 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-09-26 17:02
New changeset c8cc94a0ba4c by Ezio Melotti in branch 'default':
#1087: use proper skips in test_os.
http://hg.python.org/cpython/rev/c8cc94a0ba4c
History
Date User Action Args
2012-09-26 17:02:02python-devsetnosy: + python-dev
messages: + msg171348
2009-12-18 17:04:43pitrousetmessages: + msg96572
2009-12-18 17:02:41pitrousetnosy: + pitrou
messages: + msg96571
2009-11-17 05:11:15ezio.melottisetnosy: + ezio.melotti
messages: + msg95365
2007-11-08 14:17:59christian.heimessetstatus: open -> closed
resolution: not a bug
messages: + msg57249
nosy: + christian.heimes
2007-09-17 07:16:01jafosetpriority: normal
assignee: aimacintyre
nosy: + aimacintyre
2007-09-02 19:58:41loewissetkeywords: + patch
2007-09-02 17:38:48carsten.haesesetfiles: + py3k_os_popen_iter.patch
2007-09-02 17:37:24carsten.haesecreate