classification
Title: multiprocessing generates a fatal error
Type: crash Stage: needs patch
Components: Library (Lib) Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: multiprocessing generates a fatal error
View: 10632
Assigned To: jnoller Nosy List: bquinlan, dmalcolm, jnoller, neologix, orsenthil, pitrou, sandro.tosi
Priority: high Keywords:

Created on 2010-12-05 18:53 by bquinlan, last changed 2011-04-27 17:16 by pitrou. This issue is now closed.

Messages (9)
msg123433 - (view) Author: Brian Quinlan (bquinlan) (Python committer) Date: 2010-12-05 18:53
multiprocessing generates fatal error "Invalid thread state for this thread" in PyThreadState_Swap

This seems to happen on RHEL 5 and Centos 5.5

Here is the minimal repro:
>>> import multiprocessing.managers
>>> mpp = multiprocessing.Pool(4)
>>> sm = multiprocessing.managers.SyncManager()
>>> sm.start()

See http://bugs.python.org/issue10517 for more details
msg132410 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2011-03-28 18:17
Hi Brian,
are you able to replicate it? I just build 3.2 and default (3.3) on a Debian unstable system and wasn't able to replicate it (with a busy loop like while date ; do ./python -c "import multiprocessing.managers ; mpp = multiprocessing.Pool(4); sm = multiprocessing.managers.SyncManager(); sm.start()" ; done )
msg132418 - (view) Author: Brian Quinlan (bquinlan) (Python committer) Date: 2011-03-28 20:20
No, I wasn't able to replicate.
msg132429 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2011-03-28 21:58
can we close this issue then?
msg132634 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2011-03-31 04:08
I wonder if this is CentOS and RHEL specific. Unable to reproduce this on Ubuntu.
msg132681 - (view) Author: Dave Malcolm (dmalcolm) (Python committer) Date: 2011-03-31 15:43
This is indeed looking like it's RHEL-specific.

I was about to close it out as a duplicate of issue 10517, but I'm wondering why Brian chose to open it as a separate bug.
msg132696 - (view) Author: Brian Quinlan (bquinlan) (Python committer) Date: 2011-03-31 19:52
Filing a new bug might have been a mistake. Once the investigation in issue 10517 isolated the failure as being in a different module, I thought it best to file a new bug with a minimal repro case.

Fill free to cleanup.
msg134590 - (view) Author: Charles-François Natali (neologix) * (Python committer) Date: 2011-04-27 16:07
It's a duplicate of http://bugs.python.org/issue10517
msg134597 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2011-04-27 17:11
Dupe of issue10517
History
Date User Action Args
2011-04-27 17:16:36pitrouunlinkissue10517 superseder
2011-04-27 17:16:34pitrousetsuperseder: multiprocessing generates a fatal error
2011-04-27 17:16:34pitroulinkissue10632 superseder
2011-04-27 17:16:19pitroulinkissue10517 superseder
2011-04-27 17:16:19pitrouunlinkissue10517 dependencies
2011-04-27 17:11:18jnollersetstatus: open -> closed
resolution: duplicate
messages: + msg134597
2011-04-27 16:07:51neologixsetnosy: + pitrou, neologix
messages: + msg134590
2011-03-31 19:52:37bquinlansetmessages: + msg132696
2011-03-31 15:43:00dmalcolmsetmessages: + msg132681
2011-03-31 04:08:35orsenthilsetnosy: + dmalcolm, orsenthil
messages: + msg132634
2011-03-28 21:58:18sandro.tosisetmessages: + msg132429
2011-03-28 20:20:45bquinlansetmessages: + msg132418
2011-03-28 18:17:14sandro.tosisetnosy: + sandro.tosi
messages: + msg132410
2011-01-03 08:16:41bquinlansetstage: needs patch
2010-12-05 19:17:38bquinlansettitle: multiprocessing gene -> multiprocessing generates a fatal error
2010-12-05 19:00:39bquinlanlinkissue10517 dependencies
2010-12-05 18:53:49bquinlancreate