classification
Title: python-2.7.amd64.msi install fails
Type: behavior Stage: resolved
Components: Installation, Windows Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: An error occurred during the installation of assembly
View: 4735
Assigned To: Nosy List: Bill.Barrett, Manfred.Bartz, abelikoff, brian.curtin, jkloth, loewis, zach.ware
Priority: normal Keywords:

Created on 2010-10-28 02:58 by Manfred.Bartz, last changed 2014-06-20 18:40 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
Python-64bit_on_Win7-64_install_fails.png Manfred.Bartz, 2010-10-28 02:58 Screen capture of installer error msg
Python-64bit_on_Win7-64_sysProperties.png Manfred.Bartz, 2010-10-28 03:11
pythonInstallLog.zip Manfred.Bartz, 2010-10-29 03:48 python-2.7.amd64.msi install log
python.zip abelikoff, 2012-09-27 16:52 Log file for failed Python installation
Messages (10)
msg119753 - (view) Author: Manfred Bartz (Manfred.Bartz) Date: 2010-10-28 02:58
python-2.7.amd64.msi as well as python-2.6.6.amd64.msi fail to install on a Windows7-64 system.  In both cases with: "An error occurred during the installation of assembly 'Microsoft.VC90.CRT,version=9.0.21022.8 ...'"

See attached screen-cap.

The installer succeeds with its automatic roll-back.

python-2.7.msi (32bit installer) succeeds without any problems.
msg119754 - (view) Author: Manfred Bartz (Manfred.Bartz) Date: 2010-10-28 03:11
since the error msg suggests that the installer detected a 32 bit system, I attached a partial screen cap of system properties -- it really is a Win7-64 system, Enterprise edition.
msg119755 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2010-10-28 03:21
The 2.6, 2.7, and 3.1 amd64 installers work on my 64-bit Windows 7 machines.

Can you follow the steps in msg83923 on #4735?
msg119849 - (view) Author: Manfred Bartz (Manfred.Bartz) Date: 2010-10-29 03:48
I ran the install from the command line with:
    msiexec /i python-2.7.amd64.msi /l*v python.log
compresed log attached.

The install completed without error dialogs and a superficial test suggests that I have a working python-2.7-64 installation.
msg119850 - (view) Author: Manfred Bartz (Manfred.Bartz) Date: 2010-10-29 04:06
I uninstalled python and then re-installed it using the same procedure which caused the original problem.

This time the install succeeded without any problems.

The only explanation I can think of is that either the temporary 32-bit install or the command-line install caused a file to be installed which was missing before.

I will try this again on Monday in a virgin Win7-64 VM.
msg120715 - (view) Author: Bill Barrett (Bill.Barrett) Date: 2010-11-08 07:33
Same problem here. I also tried command line launch and get the same warning dialog as I got by clicking Firefox Download.  My install "seems" to basically work however.  I used Task Manager to kill the Install Application to avoid unrolling the installation.
msg120717 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-11-08 08:03
IIUC, Manfred's pythonInstallLog.zip is now from a successful installation, so it is unfortunately of little help. We really would need a log of a failed installation.
msg171381 - (view) Author: Alexander L. Belikoff (abelikoff) Date: 2012-09-27 16:52
Same problem for Python 3.2.3. Log file for failed installation attached.
msg171395 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-09-27 22:10
The only trace to a potential error I could find is

Assembly Error:The requested operation failed. A system reboot is required to roll back changes made.
Assembly Error (sxs): Please look into Component Based Servicing Log located at -134744968ndir\logs\cbs\cbs.log to get more diagnostic information.

So if you can find cbs.log on your system, please attach it as well. Please check that it doesn't contain any confidential information before posting it.

However, some people reported that this problem actually means that you need to reboot before you can perform the installation (because of a failure to reboot after some prior installation that required reboot). So please also reboot and report whether it solved the problem.
msg221108 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-06-20 18:40
Nearly two years since the last new information here and no obvious problem and this really looks like a duplicate of 4735 anyway; closing the issue.
History
Date User Action Args
2014-06-20 18:40:30zach.waresetstatus: open -> closed

superseder: An error occurred during the installation of assembly
versions: + Python 2.7, - Python 3.2
nosy: + zach.ware

messages: + msg221108
resolution: duplicate
stage: resolved
2012-09-27 22:10:06loewissetmessages: + msg171395
2012-09-27 16:52:48abelikoffsetfiles: + python.zip
versions: + Python 3.2, - Python 2.7
nosy: + abelikoff

messages: + msg171381
2010-11-08 08:03:05loewissetmessages: + msg120717
2010-11-08 07:33:38Bill.Barrettsetnosy: + Bill.Barrett

messages: + msg120715
versions: - Python 2.6
2010-10-29 04:06:14Manfred.Bartzsetmessages: + msg119850
2010-10-29 03:48:55Manfred.Bartzsetfiles: + pythonInstallLog.zip

messages: + msg119849
2010-10-28 23:35:51pitrousetnosy: + loewis
2010-10-28 19:57:33jklothsetnosy: + jkloth
2010-10-28 03:21:58brian.curtinsetmessages: + msg119755
2010-10-28 03:11:43Manfred.Bartzsetfiles: + Python-64bit_on_Win7-64_sysProperties.png

messages: + msg119754
2010-10-28 03:02:34brian.curtinsetnosy: + brian.curtin
type: crash -> behavior
2010-10-28 02:58:25Manfred.Bartzcreate