classification
Title: An error occurred during the installation of assembly
Type: crash Stage: resolved
Components: Installation Versions: Python 3.0, Python 2.7, Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Jakub Czaplicki, Shereef, ezio.melotti, loewis, madsdk, rwpjr66, sh.00, zach.ware
Priority: normal Keywords:

Created on 2008-12-24 02:35 by rwpjr66, last changed 2015-08-26 15:53 by Jakub Czaplicki. This issue is now closed.

Files
File name Uploaded Description Edit
python.zip Shereef, 2011-04-06 19:25 python.log zipped after being created by msiexec /i python-2.7.1.msi /l*v python.log
Messages (11)
msg78256 - (view) Author: Rodney (rwpjr66) Date: 2008-12-24 02:35
An error occurred during the installation of 
assembly 'Microsoft.VC90.CRT, version="9.0.21022.8",publicKey 
Token="1fc8b3b9a1e18e3b",processorArchitecture="x86",type="win32".  
Please refer to Help and Support for 
more information.
msg79614 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2009-01-11 19:09
Issue 4911 is a duplicate of this issue.

Could the issue be related to http://support.microsoft.com/kb/839547?
msg79615 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2009-01-11 19:11
See also 
http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=121817
msg83923 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-03-21 07:46
Can you please run the Python installer with

 msiexec /i python<xy>.msi /l*v python.log

and compress and attach the resulting log file?
msg97027 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-12-30 10:45
The same error has been reported in #7598 with Python 2.6.4.
msg127688 - (view) Author: Mads Darø Kristensen (madsdk) Date: 2011-02-01 08:42
I have this problem using Python 2.7.1 on a 32-bit Windows 7 PC.
msg133156 - (view) Author: Shereef Marzouk (Shereef) Date: 2011-04-06 19:25
here is the log.
P.S. i have VS Studio 2005 installed
msg133157 - (view) Author: Shereef Marzouk (Shereef) Date: 2011-04-06 19:30
in my last message i forgot to give more details sorry

i first installed python 2.7.1 for amd64
but it made problems iwht pywin and buildbot-slave packeges
so i wanted to install python the i386 one
and i got this error i tried amd64 again now and it installed fine
msg133158 - (view) Author: Shereef Marzouk (Shereef) Date: 2011-04-06 19:50
uhm, i restarted my pc and everything went through fine
msg221109 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-06-20 18:41
If a reboot fixed it (3 years ago), not our bug (probably, until someone can reproduce it reliably).  Closing the issue.
msg249206 - (view) Author: Jakub Czaplicki (Jakub Czaplicki) Date: 2015-08-26 15:53
Such issues are most likely caused by pending windows update that requires machine reboot. This would explain Shereef's comment in msg133158.
History
Date User Action Args
2015-08-26 15:53:11Jakub Czaplickisetnosy: + Jakub Czaplicki
messages: + msg249206
2014-06-20 18:41:43zach.waresetstatus: open -> closed

nosy: + zach.ware
messages: + msg221109

resolution: not a bug
stage: resolved
2014-06-20 18:40:29zach.warelinkissue10217 superseder
2011-04-06 19:50:23Shereefsetmessages: + msg133158
2011-04-06 19:30:53Shereefsetmessages: + msg133157
2011-04-06 19:25:50Shereefsetfiles: + python.zip
nosy: + Shereef
messages: + msg133156

2011-02-01 08:42:54madsdksetnosy: + madsdk

messages: + msg127688
versions: + Python 2.7
2010-03-22 01:34:28vstinnersetnosy: - vstinner
2009-12-30 10:45:20ezio.melottisetpriority: normal
versions: + Python 2.6
nosy: + sh.00, ezio.melotti

messages: + msg97027
2009-12-30 10:41:50ezio.melottilinkissue7598 superseder
2009-03-21 07:46:52loewissetnosy: + loewis
messages: + msg83923
2009-01-11 19:11:55vstinnersetmessages: + msg79615
2009-01-11 19:09:11vstinnersetnosy: + vstinner
messages: + msg79614
2008-12-24 02:35:39rwpjr66create