classification
Title: scripts files are not RECORDed.
Type: behavior Stage: resolved
Components: Distutils2 Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: eric.araujo Nosy List: Atsushi.Odagiri, eric.araujo, tarek
Priority: normal Keywords: patch

Created on 2010-10-25 13:55 by Atsushi.Odagiri, last changed 2011-09-02 16:05 by eric.araujo. This issue is now closed.

Files
File name Uploaded Description Edit
hello.zip Atsushi.Odagiri, 2010-10-25 13:55 package including scripts file.
test-record-scripts-10191.diff eric.araujo, 2011-06-09 14:42 review
Messages (7)
msg119550 - (view) Author: Atsushi Odagiri (Atsushi.Odagiri) Date: 2010-10-25 13:55
I wrote setup.py includes scripts with distutils2, and ran `setup.py install`.
scripts were installed in scripts directory, but not recorded in .dist-info/RECORD.


I think that `distutils2._backport.shutil:copytree` should return copied filenames.
msg119845 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-10-29 02:53
Thanks for the report.  This is indeed a bug with respect to PEP 376.

It would be too difficult to modify shutil (and copy2) to make it return filenames, but thanks to the new copy_function hook it will be easy to store filenames in a list and use that.  I’ll have to synchronize _backport.shutil with the 3.2 version first.
msg124092 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-12-15 23:09
For the record, I have started work on this, then stopped due to lack of time.  I’ll get back to it.
msg137975 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-06-09 14:42
I wrote a test but it did not fail.  Can you test it too?
msg138047 - (view) Author: Atsushi Odagiri (Atsushi.Odagiri) Date: 2011-06-10 04:44
OK, I'll test it too.
I looked sources of packaging. That use packaging.utils.copy_tree.
When I reported that problem, install_scripts used _backport.shutil.copytree. 

Maybe problem is fixed, because it reterned copied file lists.

Is that fixies applied to distutils2?
msg138085 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-06-10 15:43
> OK, I'll test it too.
Thanks.  In case you’re not sure how to test my patch, see http://docs.python.org/devguide/faq#how-do-i-apply-a-patch and http://docs.python.org/devguide/runtests

> I looked sources of packaging. That use packaging.utils.copy_tree.
> When I reported that problem, install_scripts used backport.shutil.copytree.
Ah, I see a comment in the code that copy_tree should be replaced by shutil.copytree, so we need to get the test anyway to make sure changing the code later will not cause a regression.

> Maybe problem is fixed, because it reterned copied file lists.
Indeed.

> Is that fixies applied to distutils2?
distutils2 will be recreated as a backport of packaging.  IOW, the packaging module in the 3.3 stdlib is the distutils2 project.
msg143407 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-09-02 16:05
I have added tests for scripts in RECORD and they pass.  Closing, please reopen if you can reproduce the bug.
History
Date User Action Args
2011-09-02 16:05:22eric.araujosetstatus: open -> closed
resolution: not a bug
messages: + msg143407

stage: resolved
2011-06-10 15:43:45eric.araujosetmessages: + msg138085
2011-06-10 04:44:58Atsushi.Odagirisetmessages: + msg138047
2011-06-09 14:42:16eric.araujosetfiles: + test-record-scripts-10191.diff
keywords: + patch
messages: + msg137975

versions: + Python 3.3, - 3rd party
2010-12-15 23:09:04eric.araujosetnosy: tarek, eric.araujo, Atsushi.Odagiri
messages: + msg124092
2010-10-29 02:53:12eric.araujosetassignee: tarek -> eric.araujo
messages: + msg119845
versions: + 3rd party, - Python 2.6
2010-10-25 13:55:46Atsushi.Odagiricreate