classification
Title: update the bsddb module do build with db 5.x versions
Type: compile error Stage: needs patch
Components: Build Versions: Python 2.7
process
Status: open Resolution:
Dependencies: Superseder:
Assigned To: doko Nosy List: Arfrever, BreamoreBoy, Eddie.Stanley, barry, benjamin.peterson, dmalcolm, doko, jcea, python-dev
Priority: high Keywords: patch

Created on 2013-03-19 05:34 by doko, last changed 2015-05-04 19:11 by BreamoreBoy.

Files
File name Uploaded Description Edit
bsddb.diff doko, 2013-03-19 20:40
Messages (10)
msg184598 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2013-03-19 05:34
the bsddb module is still supported in 2.7, however only builds using db versions up to 4.8, which at least some Linux distributions ship anymore.  Proposing to update the bsddb module to pybsddb 5.3.0, which supports to build using db up to 5.3.0.

The downside is that this pybsddb version drops support to build using db 4.1 and 4.2 (requires db 4.3 as a minimum). However checking at least seven year old Ubuntu 6.10 (Hardy Heron) reveals that 4.3 is already supported by this version.

I'd like to have some input/tests how the tests do go with this patch with different db versions. please report test results into this issue.
msg184676 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2013-03-19 20:48
fyi, I un-cc'd myself as I don't maintain this module anymore; jcea does. :)

I agree with the patch.  Support for anything older than 4.3 is completely pointless in 2.7 and supporting 5.x is likely required for future OS distros wanting to ship 2.7.
msg184686 - (view) Author: Roundup Robot (python-dev) Date: 2013-03-19 21:51
New changeset 83fd64c97296 by doko in branch '2.7':
- Issue #17477: Update the bsddb module to pybsddb 5.3.0, supporting
http://hg.python.org/cpython/rev/83fd64c97296

New changeset df9d2adafc2c by doko in branch '2.7':
Reindent files for:
http://hg.python.org/cpython/rev/df9d2adafc2c
msg184687 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2013-03-19 21:53
checked the update with 4.6, 5.1 and 5.3 builds.
msg184702 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2013-03-19 23:10
Berkeley DB 6.0 is inminent. A month or two.

Is this a backport "as-is" of the external pybsddb3 5.3.0 code I maintain?. If that is the case, could be some incompatibilities with current bsddb module in stock 2.7. I don't care (a lot) anymore keeping compatibility, now that pybsddb3 is an external project.

My code doesn't have some patches done in cpython version. Beware, you could revert them by mistake.
msg184708 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2013-03-19 23:51
> Is this a backport "as-is" of the external pybsddb3 5.3.0 code I maintain?.
> If that is the case, could be some incompatibilities with current
> bsddb module in stock 2.7.

yes. Could you point me to these possible incompatibilities? Afaics all test cases did succeed with this new version.
msg186337 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2013-04-08 19:28
was released with 2.7.4.
msg195336 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2013-08-16 14:54
This patch is incorrect.

It doesn't compile with Berkeley DB 5.x at all, and it doesn't allow to compile against 4.4-4.9 (previously supported). So currently it is a bit regression.

Check bug #18734.
msg195337 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2013-08-16 15:00
Note also that reusing my pybsddb project you are dropping support for several old releases of Berkeley DB that where supported by Python <2.7.4.

If somebody were using it, they are left dead in the water, just because doing a "minor" Python upgrade.
msg242570 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2015-05-04 19:11
From http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/downloads/index.html the latest version is 6.1.23.  Given the extended life span of 2.7 I'd assume that the patch here is worth updating.  See also #18734.
History
Date User Action Args
2015-05-04 19:11:36BreamoreBoysetnosy: + BreamoreBoy
messages: + msg242570
2013-09-10 21:14:48Arfreversetnosy: + Arfrever
2013-08-16 15:00:35jceasetmessages: + msg195337
2013-08-16 14:54:01jceasetstatus: closed -> open

nosy: + Eddie.Stanley
messages: + msg195336

resolution: fixed ->
stage: resolved -> needs patch
2013-08-16 14:53:22jcealinkissue18734 dependencies
2013-04-08 19:28:22dokosetstatus: open -> closed
resolution: fixed
messages: + msg186337

stage: patch review -> resolved
2013-03-19 23:51:51dokosetmessages: + msg184708
2013-03-19 23:46:34gregory.p.smithsetnosy: - gregory.p.smith
2013-03-19 23:10:10jceasetmessages: + msg184702
2013-03-19 21:53:24dokosetmessages: + msg184687
2013-03-19 21:51:04python-devsetnosy: + python-dev
messages: + msg184686
2013-03-19 20:48:40gregory.p.smithsetnosy: + gregory.p.smith
messages: + msg184676
2013-03-19 20:40:48dokosetfiles: + bsddb.diff
2013-03-19 20:40:28dokosetfiles: - bsddb.diff
2013-03-19 06:40:20gregory.p.smithsetnosy: + jcea, - gregory.p.smith
2013-03-19 05:36:34dokosetnosy: + barry, gregory.p.smith, benjamin.peterson, dmalcolm
2013-03-19 05:35:32dokosetfiles: + bsddb.diff
keywords: + patch
2013-03-19 05:34:55dokocreate