classification
Title: #include broken on FreeBSD 9.1-RELEASE
Type: Stage: resolved
Components: Versions: Python 3.4, Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: koobs, python-dev, skrah
Priority: normal Keywords: buildbot

Created on 2012-12-23 10:35 by skrah, last changed 2012-12-23 14:46 by python-dev. This issue is now closed.

Messages (5)
msg177971 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-12-23 10:35
This is strictly a buildbot issue. #include <ctype.h> seems broken on

http://buildbot.python.org/all/builders/AMD64%20FreeBSD%209.0%20dtrace%203.3/builds/248/steps/compile/logs/stdio



In file included from /usr/include/ctype.h:83,
                 from /usr/home/buildbot/python/3.3.koobs-freebsd/build/Modules/_decimal/libmpdec/io.c:33:
/usr/include/xlocale/_ctype.h:56:38: error: operator '!' has no right operand


Also note that the buildbot software reports success (i.e. the compile step is green) despite the error.
msg177987 - (view) Author: koobs (koobs) Date: 2012-12-23 14:12
This was noted by Dmitry Sivachenko during tests of my python33 port for FreeBSD, with the following commits going to HEAD (CURRENT) and RELENG_9 (9-STABLE) respectively:

http://svnweb.freebsd.org/base?view=revision&revision=243032
http://svnweb.freebsd.org/base?view=revision&revision=243331

If you need me to get any more info let me know
msg177988 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-12-23 14:26
Thanks, it's really a FreeBSD issue then. I was wondering how this
could go undetected in a production release. The reason is probably
that __GNUC_STDC_INLINE__ (which libmpdec uses) is quite rare.
msg177989 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-12-23 14:34
On second thought, gcc defines __GNUC_STDC_INLINE__ to 1, so probably
libmpdec should do the same.
msg177990 - (view) Author: Roundup Robot (python-dev) Date: 2012-12-23 14:46
New changeset f05d29353f02 by Stefan Krah in branch '3.3':
Issue #16753: Define __GNUC_STDC_INLINE__ to an integer (same as gcc).
http://hg.python.org/cpython/rev/f05d29353f02
History
Date User Action Args
2012-12-23 14:46:47python-devsetnosy: + python-dev
messages: + msg177990
2012-12-23 14:34:27skrahsetmessages: + msg177989
2012-12-23 14:26:59skrahsetstatus: open -> closed
resolution: not a bug
messages: + msg177988

stage: resolved
2012-12-23 14:12:38koobssetmessages: + msg177987
2012-12-23 10:35:15skrahcreate