This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author pi
Recipients VitP, ec2929, loewis, pi, zeromtmu
Date 2009-11-15.00:31:08
SpamBayes Score 1.6927015e-12
Marked as misclassified No
Message-id <>

I'm running Windows XP Professional and just installed Python 2.6. I
installed it for all users. Tried starting up IDLE and nothing happened.
I read the boards here, and it looks like others have had similar
troubles. I read on this board that moving the Tcl/Tk directories
helped, so I tried moving the tcl8.5 and tk8.5 directories to
C:\Python26\Lib, but IDLE still wouldn't start up. (So I moved them back.)

I opened a command shell and tried running idle that way. I will paste
the output below. Could someone help with this? Sorry if this is the
wrong place to post this problem; I am Python newbie.

C:\Python26>python Lib\idlelib\

Traceback (most recent call last):
  File "Lib\idlelib\", line 21, in <module>
  File "C:\Python26\lib\idlelib\", line 1400, in main
    shell = flist.open_shell()
  File "C:\Python26\lib\idlelib\", line 279, in open_shell
    self.pyshell = PyShell(self)
  File "C:\Python26\lib\idlelib\", line 820, in __init__
    OutputWindow.__init__(self, flist, None, None)
  File "C:\Python26\lib\idlelib\", line 16, in __init__
    EditorWindow.__init__(self, *args)
  File "C:\Python26\lib\idlelib\", line 234, in __init__
  File "C:\Python26\lib\idlelib\", line 755, in
    rf_file = open(self.recent_files_path, 'w')
IOError: [Errno 13] Permission denied: 'C:\\Documents and
Date User Action Args
2009-11-15 00:31:11pisetrecipients: + pi, loewis, zeromtmu, ec2929, VitP
2009-11-15 00:31:11pisetmessageid: <>
2009-11-15 00:31:09pilinkissue4049 messages
2009-11-15 00:31:09picreate