Author pitrou
Recipients alexandre.vassalotti, bob.ippolito, ede, josiahcarlson, loewis, mark.dickinson, mwh, pitrou, rhettinger, tim.peters
Date 2009-08-17.21:02:03
SpamBayes Score 8.2698e-09
Marked as misclassified No
Message-id <1250543111.6330.11.camel@localhost>
In-reply-to <1250539992.87.0.546479937319.issue1023290@psf.upfronthosting.co.za>
Content
Alexandre:

> Notable changes are:
> 
>   - The name of the methods have been changed to int.tobytes() and
>     int.frombytes().

Without wanting to bikeshed, I think these methods should take
underscores as other int methods already do. This kind of
inconsistencies is really annoying (have you ever used PHP? :-)).

Martin:

> Before this gets applied, a (preferably final) decision should be made
> whether it should be provided for 2.7 as well. Personally, it would be
> fine with me either way.

I'm also fine with adding it to 2.7 as well. But someone has to provide
a patch (2.7 still has both `int` and `long`, which will make the task a
bit more involved than a straight backport).
History
Date User Action Args
2009-08-17 21:02:06pitrousetrecipients: + pitrou, mwh, tim.peters, loewis, rhettinger, josiahcarlson, bob.ippolito, mark.dickinson, alexandre.vassalotti, ede
2009-08-17 21:02:04pitroulinkissue1023290 messages
2009-08-17 21:02:03pitroucreate