Author robert.kern
Recipients belopolsky, bretthoerner, chrismiles, danchr, jcea, laca, movement, rhettinger, robert.kern, ronaldoussoren, sirg3, skip.montanaro, twleung
Date 2009-04-22.06:41:44
SpamBayes Score 1.202e-05
Marked as misclassified No
Message-id <1240382506.76.0.405263264443.issue4111@psf.upfronthosting.co.za>
In-reply-to
Content
Got a bit farther. Adding this stanza to the top of phelper.d gets past
the issues in the headers:

#ifdef __APPLE__
#define _SYS_TIME_H_
#define _SYS_SELECT_H_
#define __MATH_H__
#define _OS__OSBYTEORDER_H
#define _FD_SET
#define __GNUC_VA_LIST
#endif /* __APPLE__ */


However, I now get a more legitimate dtrace compilation error that John
might be able to help us interpret:

$ dtrace -o /Users/rkern/hg/Python-2.5.4/Include/phelper.h -DPHELPER 
-I. -IInclude -I/Users/rkern/hg/Python-2.5.4/Include  -C -h -s
/Users/rkern/hg/Python-2.5.4/Include/phelper.d
dtrace: failed to compile script
/Users/rkern/hg/Python-2.5.4/Include/phelper.d: line 110: relocation
remains against user symbol D``PyEval_EvalFrameEx (offset 0x5)


I also tried running this without -DPHELPER as a regular DTrace script
rather than a ustack helper and ran into a problem that I've noticed
with any OS X Python build I've tried. I cannot seem to probe any of the
C functions in the Python interpreter. There are no simply
pid$target:a.out:: probes available. I'm wondering if that is an effect
of their being in a .framework, but I think I've been able to probe
other symbols other .frameworks.
History
Date User Action Args
2009-04-22 06:41:47robert.kernsetrecipients: + robert.kern, skip.montanaro, rhettinger, jcea, ronaldoussoren, belopolsky, movement, bretthoerner, laca, twleung, sirg3, chrismiles, danchr
2009-04-22 06:41:46robert.kernsetmessageid: <1240382506.76.0.405263264443.issue4111@psf.upfronthosting.co.za>
2009-04-22 06:41:45robert.kernlinkissue4111 messages
2009-04-22 06:41:44robert.kerncreate