Author ncoghlan
Recipients benjamin.peterson, giampaolo.rodola, gpolo, gregory.p.smith, gvanrossum, michael.foord, ncoghlan, pitrou, pupeno, purcell, rhettinger, skip.montanaro
Date 2009-04-02.12:36:40
SpamBayes Score 5.7249e-05
Marked as misclassified No
Message-id <>
Bikeshedding a bit - the 'assertGreaterEqual' and 'assertLessEqual'
method names grate on me a little. My brain has to do a double take in
order to correctly insert the implied 'Or'. This reaction is made worse
when these two methods are juxtaposed with all the other "assert*Equal"
methods like DictEqual, ListEqual, SetEqual etc.

Would it be possible to lengthen these specific names to the more
explicit "assertGreaterOrEqual" and "assertLessOrEqual"?

Some really nice additions to the test module here! :)
Date User Action Args
2009-04-02 12:36:44ncoghlansetrecipients: + ncoghlan, gvanrossum, skip.montanaro, rhettinger, gregory.p.smith, purcell, pitrou, giampaolo.rodola, pupeno, benjamin.peterson, gpolo, michael.foord
2009-04-02 12:36:43ncoghlansetmessageid: <>
2009-04-02 12:36:41ncoghlanlinkissue2578 messages
2009-04-02 12:36:40ncoghlancreate