This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author mark.dickinson
Recipients facundobatista, gvanrossum, jyasskin, mark.dickinson, rhettinger
Date 2008-02-10.15:36:42
SpamBayes Score 0.19316873
Marked as misclassified No
Message-id <>
staticmethod substituted for classmethod in r60712.

I'm not sure I like the idea of names Rational and Fraction;  the two 
classes numbers.Rational and rational.Rational are quite different beasts, 
and using two almost-synonyms for their names seems like a bad idea.
Is there some more descriptive name for numbers.Rational that might give a 
hint of its ABC-ness?
Date User Action Args
2008-02-10 15:36:44mark.dickinsonsetspambayes_score: 0.193169 -> 0.19316873
recipients: + mark.dickinson, gvanrossum, rhettinger, facundobatista, jyasskin
2008-02-10 15:36:44mark.dickinsonsetspambayes_score: 0.193169 -> 0.193169
messageid: <>
2008-02-10 15:36:43mark.dickinsonlinkissue1682 messages
2008-02-10 15:36:42mark.dickinsoncreate