Author mark
Recipients mark
Date 2007-12-12.09:56:30
SpamBayes Score 0.0222386
Marked as misclassified No
Message-id <1197453390.87.0.813702844893.issue1602@psf.upfronthosting.co.za>
In-reply-to
Content
I am not sure if this is a Python bug or simply a limitation of cmd.exe.

I am using Windows XP Home.
I run cmd.exe with the /u option and I have set my console font to
"Lucida Console" (the only TrueType font offered), and I run chcp 65001
to set the utf8 code page.
When I run the following program:

for x in range(32, 2000):
    print("{0:5X} {0:c}".format(x))

one blank line is output.

But if I do chcp 1252 the program prints up to 7F before hitting a
unicode encoding error.

This is different behaviour from Python 2.5.1 which (with a suitably
modified print line) after chcp 65001 prints up to 7F and then fails
with "IOError: [Errno 0] Error".
History
Date User Action Args
2007-12-12 09:56:31marksetspambayes_score: 0.0222386 -> 0.0222386
recipients: + mark
2007-12-12 09:56:30marksetspambayes_score: 0.0222386 -> 0.0222386
messageid: <1197453390.87.0.813702844893.issue1602@psf.upfronthosting.co.za>
2007-12-12 09:56:30marklinkissue1602 messages
2007-12-12 09:56:30markcreate