Author tonylownds
Date 2007-08-19.16:49:47
SpamBayes Score
Marked as misclassified
>I've added the message parameter for the case that we have to use a
>different error message. For example:
>self._checkReadable("Can't read from a closed socket")

Ok, I can see how that would be useful in the future even if it happens not 
to be used in your patch -- forget my previous comment.

>I've done a lot of Zope, twisted and Qt development lately. I prefer camel
>case but you are right. The Python core has to follow PEP 8. What do you
>think about _isreadable(), _iswritable(), _isseekable()?

_is*** names sound like predicate. I think your original names in lowercase would
be great: _checkreadable, _checkwritable; or with an extra underscore:
_check_readable, _check_writable.

Based on my previous comment:
>Also, shouldn't use the internal methods on parameters other than self:
>-        assert raw.seekable()
>+        raw._checkSeekable()

...perhaps _checkreadable, etc should be functions?

Date User Action Args
2007-08-23 15:59:37adminlinkissue1771364 messages
2007-08-23 15:59:37admincreate