This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author andrei.avk
Recipients andrei.avk, ned.deily, paul.moore, ronaldoussoren, steve.dower, tim.golden, ymerej, zach.ware
Date 2021-11-29.06:04:39
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
The issue seems to be that there was a change between 3.7.7 and 3.8.6, - multiprocessing started using pickle dump / load which cannot handle double underscore methods.

See #33007 for a reproducer with pickle.

I'm using MacOS and this multiprocessing example in OP works fine in 3.7.7 and raises the same error as OP in 3.8.6. So from my side at least it doesn't appear to be a cross-platform issue (but I'm not sure why it worked on Linux on 3.8.10 for OP).

I've also reproduced it on the latest 3.11.

So this appears to be a regression and if there's an easy fix, it's probably worth fixing.
Date User Action Args
2021-11-29 06:04:39andrei.avksetrecipients: + andrei.avk, paul.moore, ronaldoussoren, tim.golden, ned.deily, zach.ware, steve.dower, ymerej
2021-11-29 06:04:39andrei.avksetmessageid: <>
2021-11-29 06:04:39andrei.avklinkissue44675 messages
2021-11-29 06:04:39andrei.avkcreate