Author Anthony Sottile
Recipients Anthony Sottile, JDLH, cheryl.sabella, docs@python, eric.araujo, ezio.melotti, gregory.p.smith, jdemeyer, mdk, miss-islington, steven.daprano, terry.reedy, willingc
Date 2021-01-05.00:42:35
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1609807355.44.0.833214595396.issue36675@roundup.psfhosted.org>
In-reply-to
Content
should the minimum sphinx version be bumped and/or this reverted: https://github.com/python/cpython/blob/f7f0ed59bcc41ed20674d4b2aa443d3b79e725f4/Doc/conf.py#L48

this change breaks, for example, sphinx 1.8.5 while building for ubuntu 20.04

The directive used here requires sphinx>=3.2.0

I notice some other attempts have been made to make the docs more compatible with sphinx 1.x in this release as well so there might be conflicting directions here: https://github.com/python/cpython/commit/b63a620014b67a6e63d10783149c41baaf59def8
History
Date User Action Args
2021-01-05 00:42:35Anthony Sottilesetrecipients: + Anthony Sottile, terry.reedy, gregory.p.smith, ezio.melotti, eric.araujo, steven.daprano, docs@python, jdemeyer, willingc, mdk, JDLH, cheryl.sabella, miss-islington
2021-01-05 00:42:35Anthony Sottilesetmessageid: <1609807355.44.0.833214595396.issue36675@roundup.psfhosted.org>
2021-01-05 00:42:35Anthony Sottilelinkissue36675 messages
2021-01-05 00:42:35Anthony Sottilecreate