Author mbussonn
Recipients ezio.melotti, mbussonn, mrabarnett
Date 2019-12-05.16:56:07
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1575564967.92.0.182367459899.issue38981@roundup.psfhosted.org>
In-reply-to
Content
better error/exception name for re.compile error. 

Currently the error raise by re.compile when it fails to compile is `error` defined in sre_constants.py: 

```
class error(Exception):
    """Exception raised for invalid regular expressions.

```

This is quite disturbing as most exception start with an uppercase and have a tiny bit more descriptive name. 

Would it be possible to have it renamed as something more explicit like `ReCompileError`, and still keeping the potential `error` alias as deprecated ?
History
Date User Action Args
2019-12-05 16:56:07mbussonnsetrecipients: + mbussonn, ezio.melotti, mrabarnett
2019-12-05 16:56:07mbussonnsetmessageid: <1575564967.92.0.182367459899.issue38981@roundup.psfhosted.org>
2019-12-05 16:56:07mbussonnlinkissue38981 messages
2019-12-05 16:56:07mbussonncreate