This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author pablogsal
Recipients belopolsky, christian.heimes, eric.smith,, martin.panter, pablogsal, remi.lapeyre, rhettinger, terry.reedy, tshepang
Date 2019-01-18.18:36:12
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
> 1. The name "topsort" is most naturally parsed as "top sort" which could be misinterpreted (as a sort that puts items on top in some way). If the name must be abbreviated then "toposort" would be better.

I totally agree that `topsort` is a bad name, I used it more or less as a dummy for starting the discussion about the implementation.

> 2. "Topological sort" is a terrible name: the analogy with topological graph theory is (i) unlikely to be helpful to anyone; and (ii) not quite right. I know that the name is widely used in computing, but a name incorporating "linearize" or "linear order" or "total order" would be much clearer.

Topological sort (not as the function name) but as an operation is a very well known concept and is well defined. If you are referring to not use "Topological Sort" in the docstrings or the documentation, I strongly oppose.

Regarding the interface, I am more happy to change it once there is an agreement. I am still awaiting Raymond's comments regarding this so we can start discussing.
Date User Action Args
2019-01-18 18:36:13pablogsalsetrecipients: + pablogsal, rhettinger, terry.reedy, belopolsky, eric.smith, christian.heimes, tshepang,, martin.panter, remi.lapeyre
2019-01-18 18:36:12pablogsalsetmessageid: <>
2019-01-18 18:36:12pablogsallinkissue17005 messages
2019-01-18 18:36:12pablogsalcreate