Author rhettinger
Recipients aleax, mark.dickinson, pitrou, remi.lapeyre, rhettinger, serhiy.storchaka, tim.peters, vstinner, xtreak
Date 2019-01-05.02:48:13
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1546656493.66.0.66033310358.issue35606@roundup.psfhosted.org>
In-reply-to
Content
I don't like the name overlap with itertools.product().  Currently, math and itertools have no overlapping names.  Also, I expect that like sum(), the prod() function will be used with generator comprehensions and should best be kept short and not dominating the rest of the expression.

It's true that factorial is spelled-out, but that was probably a mistake -- it has been somewhat awkward in expressions that contain factorial terms.  Ideally, we would have comb, perm, fact, and prod.
History
Date User Action Args
2019-01-05 02:48:14rhettingersetrecipients: + rhettinger, tim.peters, aleax, mark.dickinson, pitrou, vstinner, serhiy.storchaka, remi.lapeyre, xtreak
2019-01-05 02:48:13rhettingersetmessageid: <1546656493.66.0.66033310358.issue35606@roundup.psfhosted.org>
2019-01-05 02:48:13rhettingerlinkissue35606 messages
2019-01-05 02:48:13rhettingercreate