Author terry.reedy
Recipients cheryl.sabella, terry.reedy
Date 2018-05-25.00:39:10
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1527208751.0.0.682650639539.issue22703@psf.upfronthosting.co.za>
In-reply-to
Content
An experienced non-CS computer user I asked does not like 'toggle x' or 'switch x', but would like whichever of 'show x' and 'hide x' is appropriate (rather than both).  For breakpoints, this would mean one menu entry, either 'set breakpoint' or 'clear breakpoint', rather than both (as currently).

A few Menu entries are labelled 'Show x'.  They don't need a 'Hide' menu  variant as hiding is done otherwise.

Checkmarks are OK, but she would prefer an empty box or circle as an dialogs, so that clicking more obviously means 'turn on' when in the 'off' state.

It occurs to me now, after  at least 20 years of using menus,  that the logic of 'blank' is that 'blank' means 'do something', so that 'check' means 'something was done, undo it'.  But I think that clicking 'clear breakpoint', for instance, is clearer than clicking 'v breakpoint', where 'v' represents a checkmark'.
History
Date User Action Args
2018-05-25 00:39:11terry.reedysetrecipients: + terry.reedy, cheryl.sabella
2018-05-25 00:39:11terry.reedysetmessageid: <1527208751.0.0.682650639539.issue22703@psf.upfronthosting.co.za>
2018-05-25 00:39:10terry.reedylinkissue22703 messages
2018-05-25 00:39:10terry.reedycreate